Visual Studio Code on Fedora 39 / Gnome - lockups

2 views
Skip to first unread message

Tom

unread,
Feb 20, 2024, 9:55:09 AMFeb 20
to Milwau...@googlegroups.com
Anyone else using Visual Studio Code on Gnome?
 
Overall, it works fine, but the SaveAs dialog nearly always locks it up. And sometimes it doesn't. When it doesn't lock up, it opens the expected Save As dialog and prompts for a filename, in the current working directory for code.
 
Most of the time, it puts up a brief message a little below the top, centered, which says '"Save As" is ready' and will not respond to mouse clicks or keyboard. The mouse pointer moves around, but ignores clicks. I can however click the Gnome Close Window [X] and that does close it.
 
After restating VSCode: If the code I was trying to save hadn't been given a name before, it comes back as "untitled" and then I can save it.
 
I have scoured the intertubes looking for that message, and failing to find it. There are numerous references to lockup on save, and I have disabled hardware acceleration and some git integration features in response, but to no avail.
 
I'd be happy to hear and clues you might have.
 
P.S. I'm learnin' me some Python. Again.
 
-T
 

Tom

unread,
Feb 20, 2024, 9:59:40 AMFeb 20
to Tom, Milwau...@googlegroups.com
P.P.S I'm running Gnome 45.4 on Wayland.

Sean Malloy

unread,
Feb 20, 2024, 1:45:15 PMFeb 20
to Milwau...@googlegroups.com

--
Homepage: http://www.milwaukeelug.org/home
This forum online: https://groups.google.com/forum/#!forum/MilwaukeeLUG
---
You received this message because you are subscribed to the Google Groups "Milwaukee Linux User's Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to MilwaukeeLUG...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/MilwaukeeLUG/5701.1244570965.1708440904%40gmail.com.

Tom

unread,
Feb 20, 2024, 2:16:29 PMFeb 20
to Milwau...@googlegroups.com
Gnome extension Grand Theft Focus installed-- it worked once for me. I'll know if it's a long-term fix once I roll through a few more source files. Usually, creating a new source file and doing the first SaveAs is what does it. The bizarre thing is how random it is-- It may work great for a while, then lock up, or the first attempt to save a new file causes the problem.
 
If this is really the solution, I'd be very curious to know where the hidden dialog is. When this first started happening to me, I looked everywhere for a hidden dialog, to no avail.
 
Thanks very much for the tip.

Tom

unread,
Feb 21, 2024, 9:37:41 AMFeb 21
to Milwau...@googlegroups.com
And it's Sean Malloy for the win! No more lockups since yesterday. Thanks!
 
At 12:45 PM 2/20/2024 -0600, Sean Malloy wrote:
Reply all
Reply to author
Forward
0 new messages