Mididings in UbuntuStudio 20.04

108 views
Skip to first unread message

Joao Goncalves

unread,
May 14, 2020, 4:21:36 PM5/14/20
to mididings
Hi everybody! 
I had mididings working some ubuntu versions ago but to be honest i haven't worked with it for quite sometime so i don't know when it got broken. 
I installed a fresh new UbuntuStudio 20.04 and can't make mididings work in it. I tried with your directions here in this topic but it gives me this:
joao@LG15:~$ mididings
Traceback (most recent call last):
  File "/usr/local/bin/mididings", line 20, in <module>
    import mididings
  File "/usr/local/lib/python2.7/dist-packages/mididings/__init__.py", line 13, in <module>
    import _mididings
ImportError: /lib/x86_64-linux-gnu/libboost_python38.so.1.71.0: undefined symbol: _Py_tracemalloc_config
joao@LG15:~$ 
Is there any more step i'm missing? (I suppose it is something with boost, but...)
Thank you for you're work trying to help us

STEFETS - https://github.com/stefets/live-config/

unread,
May 17, 2020, 9:28:40 AM5/17/20
to mididings
Hi Joao,

I think you have mididings for Python2.7 and libboost for Python 3.8

Try to find _mididings.so in your system and do ldd command on it.

This is my output of ldd command, look at my libboost version 

stefets@PC1:/usr/local/lib$ ldd /usr/local/lib/python2.7/dist-packages/mididings-2015+rbbec99a-py2.7-linux-x86_64.egg/_mididings.so
linux-vdso.so.1 (0x00007ffe75cca000)
libboost_python-py27.so.1.65.1 => /usr/lib/x86_64-linux-gnu/libboost_python-py27.so.1.65.1 (0x00007fc60fd0f000)
libboost_thread.so.1.65.1 => /usr/lib/x86_64-linux-gnu/libboost_thread.so.1.65.1 (0x00007fc60faea000)
libasound.so.2 => /usr/lib/x86_64-linux-gnu/libasound.so.2 (0x00007fc60f7e3000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fc60f45a000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fc60f0bc000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fc60eea4000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fc60ec85000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fc60e894000)
libboost_system.so.1.65.1 => /usr/lib/x86_64-linux-gnu/libboost_system.so.1.65.1 (0x00007fc60e68f000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fc60e487000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fc60e283000)
/lib64/ld-linux-x86-64.so.2 (0x00007fc6102f1000)

Hope this help !

Stephane Gagnon

Joao Goncalves

unread,
May 19, 2020, 8:55:24 AM5/19/20
to mididings
Hi Stéphane.
Thank you for your effort.
I have been trying to make it work with the same version as yours, but it kept not cooperating with me.
I tried with AvLinux 20 and i could make it work finaly.
Now, to start working with this thing. I have to restart learning again as i didn't really have ever done something useful with mididings before.
Again, thank you

STEFETS - https://github.com/stefets/live-config/

unread,
May 21, 2020, 8:23:05 AM5/21/20
to mididings
Hi Joan, 

Thanks for the feedback !

Yes there is a learning curve with mididings, it's complex but so powerfull.

Maybe you can check my repo on guithub you will find lots of mididings syntaxes.


Thanks!

Joao Goncalves

unread,
May 21, 2020, 5:56:54 PM5/21/20
to midi...@googlegroups.com
Hi Stephane.
I will for sure. 
Thank you

--
You received this message because you are subscribed to a topic in the Google Groups "mididings" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/mididings/xxxphJOUm7I/unsubscribe.
To unsubscribe from this group and all its topics, send an email to mididings+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mididings/4ae36533-8c3e-43bb-987a-f0492c8a64d7%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages