Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.
Dismiss

Print Spooler Errors/Problems-You Wont BELIEVE The Cause

6,278 views
Skip to first unread message

California4x4

unread,
Sep 18, 2008, 9:51:01 AM9/18/08
to

--
California4x4

Suddenly my printers stopped working, all of them, and the scanner, my
system started to bog down and I got SPOOLSV.EXE errors. I did CheckDisks, I
did Mem Checks, I scanned for Viruses and Trojans, cleaned up the Registry,
did a CHKDSK /R from the XP install CD... nothing! Then I did some more
research and came up with the cause and the solution which you WILL want to
know about.

I saw a blog entry about wiping out the contents of windows\system32\spooler
but thought that a bit drastic. However. I went into that folder and
started looking around.

In windows\system32\spool\printer I found two files that did NOT belong
there. How they got there is anyone's guess. They were: 0002.SPL and
0002.SHD, both of which are Shockwave Flash objects.

When I deleted these (and it took some doing) EVERYTHING returned to normal.

Apparently the Spooler does NOT know what to do with these file types in the
..\printer folder (understandable) so it kept chewing and chewing and chewing
and chewing on them to the point where I couldn't bring up my list of
printers, couldn't reinstall printer drivers, kept getting DeviceIO
Notification popups, constantly got SPOOLSV.EXE "could not read" memory error
instructions, and so forth during shutdown attempts.

So, the moral is, when you are having weird Spooler errors, check out your
windows\system32\spool\printer folder and look for "weird" stuff.

Hope this helps and I hope MS sees this and fixes their Spooler so it won't
chew away forever on "weird" objects.

ViperCag

unread,
Sep 19, 2008, 1:50:01 AM9/19/08
to
Hey California4x4

Thanks for this !! - I think you have just saved my life.

I have had nothing but dramas over the last week with HP Printers, and my
Spooler !! - I have been on the phone to Microsoft & HP - & nothing !!

So when I saw your post, I followed the instructions, - and low & behold,
there in the PRINTER folder, were three Shockwave files !!!!

THese are now deleted, and I am hoping that everything should be back to
normal !!

Cheers

Alan Morris [MSFT]

unread,
Sep 19, 2008, 12:59:46 PM9/19/08
to
shd is the spooler scheduling file. It contains data about the job title,
the print driver, and the printer. It's partly text based and you can open
this file in notepad.

the slp file is the actually print data. It's been this way for over 15
years. I think that's older than Shock Wave.

Most likely there is a job scheduled to the MS Document Writer (whatever MS
Office installs for a printer) and a job was printed to this printer that
does not exist and was stuck in a loop until you deleted the job, the
spooler no longer did was it is coded to do with the data, send to GDI for
rendering to the print device.

--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/search/?adv=1

This posting is provided "AS IS" with no warranties, and confers no rights.

"ViperCag" <Vipe...@discussions.microsoft.com> wrote in message
news:5C5E63E0-0694-4A52...@microsoft.com...

in Oregon@discussions.microsoft.com Laura in Oregon

unread,
Oct 14, 2008, 7:08:04 PM10/14/08
to
California:

Thank you so much for your post. We just had the same problem. Your
solution worked.

Did you by any chance recently download something from Windows?

Pantsy

unread,
Oct 16, 2008, 10:48:02 AM10/16/08
to
I've tried doing this several times and I still can't print to my printer and
the Shockwave files keep coming back. Anybody have any ideas?

"California4x4" wrote:

>
> --
> California4x4

Lem

unread,
Oct 16, 2008, 12:52:43 PM10/16/08
to
California4x4 wrote:
> In windows\system32\spool\printer I found two files that did NOT belong
> there. How they got there is anyone's guess. They were: 0002.SPL and
> 0002.SHD, both of which are Shockwave Flash objects.

Just to add to Alan's cogent information, do not make the mistake of
thinking files *must* be a particular format just because Windows
"thinks" they are and assigns a particular icon to them.

Windows uses the three-letter file name extension to determine what
"kind" of a file it is dealing with. Not infrequently, the designers of
different application programs end up choosing the same three-letter
file extension to describe files that have nothing whatsoever to do with
each other. The icon that's displayed and the corresponding
description that appears in Windows Explorer just represent the last
application that has "told" Windows that it "owns" files with that
extension.

As Alan says, the SPL and SHD files in the \spool\printer directory
undoubtedly are print-related files and not flash files.

If you want to know what kind of file something is based on its file
extension, www.filext.com is a good place to start. It reveals, for
example, that an *.SPL file might be:

(a) a Compressed Archive File;
(b) a Digitrakker Sample file;
(c) an Adobe (or MacroMedia) Flash FutureSplash Document file;
(d) a Bioware Infinity Game Engine Spell file;
(e) a Microsoft printer spool file;
(f) a Sample File;
(g) a Shockwave Flash Object;
(h) a SoniqCast SoniqSync file;
(i) a Sound file;
(j) a Spell Checker file;
(k) an ABACOM Ingenieurbüro sPlan Circuit Diagram file;
(l) a Split Files Shell Extension file;
(m) a Sprint Customized Printer Driver file; or
(n) an Unknown Apple II File (found on Golden Orchard Apple II CD Rom).

For details, see http://filext.com/file-extension/spl
--
Lem -- MS-MVP

To the moon and back with 2K words of RAM and 36K words of ROM.
http://en.wikipedia.org/wiki/Apollo_Guidance_Computer
http://history.nasa.gov/afj/compessay.htm

kielcd

unread,
Feb 2, 2009, 2:05:01 AM2/2/09
to
Last month I bought a new HP Printer, HP Deskjet F4280. Ever since I have
had nothing but problems with the printer spooler. I keep getting the
following error message when I try to print:

Spooler subsystem app has encountered a problem and needs to close.

I have tried to be resourceful and have followed nearly every recommendation
on the microsoft knowledge database and other sites to fix the problem. I
have deleted all printer drivers several times, and reinstalled the software
for the HP printer to no avail. I've followed Alan Morris' MFT advice and
his links to Bruce's aids and none of them have worked.

What's my next move? I can only get Word docs to print. No excel,
internet, etc.

Thanks,

Cheyenne

Alan Morris [MSFT]

unread,
Feb 2, 2009, 1:03:16 PM2/2/09
to
the next solution is to find the problem. If there is a DRwatsn.log file
(unsure on the name) in \windows you can search for FAULT and see what the
failing module is.

Or you can debug the spoolsv.exe process. Make sure the print spooler
service is started.

Launch task manager, go to Processes, add the PID column, note the PID
(Process ID) for spoolsv.exe.

Open a command window and type

ntsd -p [PID for spoolsv] -g -G


you will see a window open with a bunch of module load data. Now print
within the application where the spooler fails. You will not be informed
that the spooler failed but the process will be at a prompt where it failed.
Type k to dump the faulting stack and send it back. You can let the
spooler service terminate by entering q [ENTER] at the prompt. If you mess
this up the first time just restart the spooler in the command window "net
start spooler"

ModLoad: 77ba0000 77bfa000 E:\3576SRV\system32\msvcrt.dll
ModLoad: 77c00000 77c49000 E:\3576SRV\system32\GDI32.dll
ModLoad: 77380000 77412000 E:\3576SRV\system32\USER32.dll
ModLoad: 77da0000 77df2000 E:\3576SRV\system32\SHLWAPI.dll
ModLoad: 7c8d0000 7d0d4000 E:\3576SRV\system32\SHELL32.dll
ModLoad: 73070000 73097000 E:\3576SRV\system32\WINSPOOL.DRV
ModLoad: 76290000 762ad000 E:\3576SRV\system32\IMM32.DLL
ModLoad: 62d80000 62d89000 E:\3576SRV\system32\LPK.DLL
ModLoad: 75490000 754f1000 E:\3576SRV\system32\USP10.dll
ModLoad: 4b8d0000 4b921000 E:\3576SRV\system32\MSCTF.dll
ModLoad: 75e60000 75e87000 E:\3576SRV\system32\apphelp.dll
ModLoad: 4dc30000 4dc5e000 E:\3576SRV\system32\msctfime.ime
ModLoad: 77670000 777a4000 E:\3576SRV\system32\ole32.dll

(324.890): Break instruction exception - code 80000003 (second chance!!!)
eax=7ffd5000 ebx=00000001 ecx=00000002 edx=00000003 esi=00000004
edi=00000005
eip=7c822583 esp=00a3ffcc ebp=00a3fff4 iopl=0 nv up ei pl zr na po
nc
cs=001b ss=0023 ds=0023 es=0023 fs=0038 gs=0000
efl=00000246
*** ERROR: Symbol file could not be found. Defaulted to export symbols for
E:\3
576SRV\system32\ntdll.dll -
ntdll!DbgBreakPoint:
7c822583 cc int 3
0:001>

--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/search/?adv=1

This posting is provided "AS IS" with no warranties, and confers no rights.

"kielcd" <kie...@discussions.microsoft.com> wrote in message
news:8EC114B2-7873-4AAF...@microsoft.com...

Fanflame

unread,
Nov 13, 2009, 6:50:07 AM11/13/09
to

Dear Sirs,

I realise that this is an old posting but I have come across it in my
search for the reason the my Print spooler hangs. I get virtually the
same as everyone else here and it has been the same way for two years
now!

I look after over a hundred users and have 55 users on Citrix. It is on
the Citrix Servers that I have the issue that the Printers hang and I
just created a batch file to stop the spooler (and Citrix dependants)
move the printing Queue to a spooler dump in a Temp folder (so that I
can inspect/see what was printed, where it was printed too, the
time/date etc) Then the batch file deletes the content of the spooler
and restarts the spooler again!

This batch file has also been set so that it is the program that the
spooler uses if it fails for any reason, obviously it tries three time
and then hangs.

When it hangs I have to physically go in and do it, restart the server
and hey-ho, it works again until next time!

However, I would really like to get to the bottom of it and wondered if
anyone did come up with a reason that the *.SPL file - which by the way
is always 0KB is associated to Shockwave??

If anyone does read these old posts - especially the Windows Printing
team I would love an answer or to start off a new thread?

Suggestions?

Enjoy the day!

Brian
aka: Fanflame.


--
Fanflame
------------------------------------------------------------------------
Fanflame's Profile: http://forums.techarena.in/members/115595.htm
View this thread: http://forums.techarena.in/xp-print-fax/1040367.htm

http://forums.techarena.in

Porter@discussions.microsoft.com Geoff Porter

unread,
Dec 2, 2009, 2:55:01 AM12/2/09
to
My application fails to print with 'out of memory'

I tried ntsd -p [PID for spoolsv] -g -G and ended up with an error indication
that indicated:
The call to LoadLibrary(ext) failed with error 2.
The call to LoadLibrary(uext) failed with error 2.

Is this related to your help and can you help me?

Fritzchen

unread,
Jan 7, 2010, 5:01:19 AM1/7/10
to

This thread gave me some clues to a problem I am having, and hope
someone has the solution since this thread started! I am working on a
small XP home network with a USB printer shared across the network. The
symptoms are: The host computer (attached to the printer) has no
problems printing to the Canon iX4000. Another computer on the network
can access the printer no problems at all, EXCEPT .. that sometimes you
send jobs to the printer and they disappear off the queue without
printing. Then, sometimes it would print successfully and then not at
all. Weird.

So, after the tip off about the FP00000 and FP00000.SHD files, I
checked the system32\spool\PRINTERS folder on the host machine and found
the offending files there.

I discovered that the networked computer would not print to the printer
AS LONG as the 2 files still existed in the PRINTERS folder. I watched
with some interest, as these files remained in there, and then at some
indeterminate and variable time, the files would clear off. During this
time, the host computer could still print without problem. As soon as
the files disappeared (and you could do that by stopping and restarting
the Service), you could print to the printer. There seemed to be no
rhyme or reason as to what the time interval of deletion of the files
would be.

I was also told that the network owners had tried to fix the problem by
switching the printer from one computer to the other, but it the problem
just moved from one computer to the other!

So, what has to be done to automatically remove these offending files
after the printing has been done?


--
Fritzchen
------------------------------------------------------------------------
Fritzchen's Profile: http://forums.techarena.in/members/171604.htm

BobBatIps

unread,
Feb 6, 2010, 8:32:11 PM2/6/10
to

Thanks. Tried several attempts at resolving this problem from the
microsoft world but they failed. Your suggestion to delete shock wave
files in the spool\printers directory did the trick. Unfortunately was
unable to determine how they got there.


--
BobBatIps
------------------------------------------------------------------------
BobBatIps's Profile: http://forums.techarena.in/members/182351.htm

mick...@gmail.com

unread,
Oct 15, 2014, 9:17:37 PM10/15/14
to
I am having the same trouble now printing from google chrome (IE works fine) I dont beleive it is a "shockwave file" issue as these files are just incorrectly being identified as shockwae files when they are spool files?

In any case Ive deleted same to no effect

any other suggestions?? Google?
0 new messages