Possible fix for USB Mass storage problems

38 views
Skip to first unread message

Stan Rose

unread,
Nov 14, 2003, 8:17:48 AM11/14/03
to
There have been several postings about problems with USB
mass storage devices. I had this problem and attempted to
fix it, as documented in a thread "USB Mass Storage - Not
Recognised in." that started on 11/4 at 2:15am. I fixed
it for me by doing a clean install.

Before I did the reinstall, I had filed an incident
report with MS. Unfortunately, for me, the response got
to me after I did the reinstall. MS said it is OK to post
it here for anyone else with the problem. He said it was
specific to my problem, but can be adapted to fit to the
circumstances.

===========================================
Dear Stan,

Thank you for your reply. According to the information, I
recommend you follow these steps to resolve this issue:

Step 1: Remove Hidden Devices

1. Click Start. Click Run. Type cmd and press OK.
2. Type "set DEVMGR_SHOW_DETAILS=1" (without quotation
marks) and press Enter.
3. Type "set DEVMGR_SHOW_NONPRESENT_DEVICES=1" (without
quotation marks) and Press Enter.
4. Type "start devmgmt.msc" (without quotation marks) and
click press Enter.
5. Click View. Click Show hidden devices.
6. Click "+" to expand Imaging devices, Unknown devices
and USB devices.
7. Are there any digital camera devices and unknown
devices (including grayed out devices)? If so, please
right click it and click Uninstall.

Step 2: Remove all oem*.inf files

=========================

1. Click start and click run then under the run line type
in the command "cmd" (without the quotation marks)

2. In the command line, type in the following (without
the quotes) and press enter after each command:

"cd \windows\inf"
"ren infcache.1 *.old"
"ren oem*.inf *.old"
"del C:\windows\setupapi.log"
"exit"

Step 3: Removing all entries under
HKEY_LOCAL_MACHINE/Enum/USB that start with VID

==========================================================
========

Removing the VID entries from the registry will cause
them to be redetected at restart.

CAUTION: If you have a USB keyboard or mouse, do not
remove the VID entry for these devices, otherwise,
Windows may not restart correctly.

1. Click Start and click Run. Type regedit and click OK.
The Registry Editor window will open.

2. Go to
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\USB.

3. Highlight and delete all the VID_.... entries.

Permissions may be set allowing the deletion of the VID_
entries by following the steps below:

a) Right-click the key to be deleted, and then click
Permissions. The VID_... Permissions window will open.
b) With Everyone highlighted in the Group or User
name section, select Full Control in the Permissions
section.
c) Click Apply, and then click OK.

4. Turn off the computer.

Step 4: Reconnect the digital camera to the computer
system:

=============================

1. With the computer system turned off, reconnect
the Sony DSC-P50 camera to the USB port.
2. Restart the computer.
3. After the Windows operating system has finished
restarting, plug the digital camera into the electrical
outlet.
4. A New Hardware Detected window should open and
reload the drivers.

If the camera still cannot work, I recommend you plug the
camera to another Windows XP computer (Desktop) to test
whether this camera works. I suspect it is an
incompatibility issue.

Thank you for your time. I look forward to your reply.

Best Regards,

Microsoft Windows Support Professional


(I then asked if it is ok to post it, and received this
email, Stan)

Thank you for your reply. These steps are not in
Knowledge Base. It is OK to share it on forums. However,
these steps are designed according to your System
Information and other information. They may not work for
other situation. The principle is the same: remove
redundant registry and drivers.

Thank you for keeping in touch.

Best Regards,

Microsoft Windows Support Professional

Bill

unread,
Nov 14, 2003, 10:04:40 AM11/14/03
to
Stan,

Was your reply meant for me, Bill, who posted a problem
with a USBDrive?

In any case, thanks much. I think this is what I'm
looking for.

Bill

>.
>

Stan Rose

unread,
Nov 14, 2003, 10:38:59 AM11/14/03
to
I was posting this fresh for everyone who was reporting
this type of problem and looking for a fix (I wish I had
had it before I spent a day doing a clean install and
installation of a boat load of applications).

Stan

>.
>

Paulette Gibson

unread,
Nov 18, 2003, 2:15:36 AM11/18/03
to
Thanks so much for posting Microsoft's response to this
problem. I post the following so that someone else might
find the answer to THEIR problem with this.

I have a Lexar Media USB Jumpshot - that's a removable
media storage device for Compact Flash Cards (for digital
cameras). When installed, this device showed in the
Device Manager as working properly, but would not show up
in My Computer.

I had just done a clean install of XP from totally
upgrading my system. I also have Roxio's Easy CD Creator
installed, which has caused various problems with
removable media. Looking in the System Information area,
I discovered that the Jumpshot was listed in Problem
Hardware with Error Code 39. I tried searching the XP
Help and Support, then the Microsoft Support Knowledge
Base for Windows XP. Although I found similar problems,
they were not specific to mine. I even searched these
forums and came up with nothing.

However, I started looking post by post backward from the
17th (today - well yesterday now) and finally came across
yours. The info that Microsoft allowed you to post here
solved my problem and the Jumpshot now works just fine!

So, again, thanks for taking the time to post their
solution here.

>.
>

Stan Rose

unread,
Nov 18, 2003, 1:26:33 PM11/18/03
to
Glad to see it was useful. I don't know why they don't
publish it as a KB article.

Here's another trick I stumbled on yesterday related to
USB. I plugged in my Sandisk reader and the drives
appeared in the USB removal tool in the bottom right, but
not in Explorer. I feared I had fallen back into the
problem. I took a stab, however, at accessing the USB
drive by typing "L:\" (without the quotes) into
Explorer's address bar and - low and behold - the drive
worked fine with all data fully available. So, the trick
is that even if it doesn't appear in Explorer, manually
type in its address and you may be able to get to it.
After I rebooted, Explorer showed the USB storage devices
again.

Stan

>.
>

Reply all
Reply to author
Forward
0 new messages