Dynamic Subview Background

40 views
Skip to first unread message

Stevie BM

unread,
Aug 1, 2003, 8:00:52 AM8/1/03
to
Hi,
As people may have noted from my two previous posts on
this newsgroup, I'm trying to make a rather complex WMP
skin at the moment.

I have almost found a solution to my
previous "WMPImage_AlbumArt" problem, where
the "WMPImage_AlbumArtLarge" was too large, and
the "WMPImage_AlbumArtSmall" was too small.
The solution - use the image as the backgroundimage of a
SUBVIEW element, with the resizebackgroundimage attribute
set to true.

I have, however, come to another stumbling block - it
appears that when you attempt to change the
backgroundimage attribute of a subview, the image either
doesn't change, or becomes invisible.

Any assistance with this problem is greatly appreciated.

Steve

Stevie BM

unread,
Aug 1, 2003, 8:17:19 PM8/1/03
to
Hi again,
I've discovered, after much toying with my skin, that
this problem only seems to occur when I set the
backgroundImage attribute of a view or subview to the
value "WMPImage_AlbumArtLarge". If I use a valid
png/bmp/whatever, it appears to work...

Any suggestions as to why it won't pick up the album art
in the code, but setting this attribute in the XML works?
Further to this, why can I set a button's image like
this, but not a subview's background image?

Steve

>.
>

Stevie BM

unread,
Aug 1, 2003, 8:24:41 PM8/1/03
to
Hi all,
I found the solution at long last - set the
[subview].backgroundImage = "", and then set it to
either "WMPImage_AlbumArtLarge" (or small, if you prefer).

Then you can have a dynamically resized album art, which
updates when your current media changes.

Steve

>.
>

Deyan Atanasov [MVP]

unread,
Aug 14, 2003, 10:58:20 AM8/14/03
to
Stevie, That's great!


"Stevie BM" <stev...@hotmail.com> wrote in message
news:041701c3588c$76ed6140$a401...@phx.gbl...

Reply all
Reply to author
Forward
0 new messages