windows journal won't load anymore??? error inking components????

1 view
Skip to first unread message

steve

unread,
Jun 10, 2003, 1:43:32 AM6/10/03
to
windows journal used to run. Now I get an error that
can't be fixed by rebooting.

"windows journal cannot start.

There was an error initializing inking components"

what the f does that mean?????

help???

Chris H.

unread,
Jun 10, 2003, 2:11:24 AM6/10/03
to
When did this error start, Steve? Are you running System Restore? If so,
go to a Restore Point prior to the error starting. If you can't do that, go
to Start/Run and type "Journal /RepairNoteWriter" and click the OK button.
--
Chris H.
Microsoft Windows MVP/Tablet PC
Tablet PC Universe - www.tabletpcuniverse.net
Tablet PC Chat - http://thetabletpc.net/support.htm
Associate Expert
Expert Zone - www.microsoft.com/windowsxp/expertzone

"steve" <st...@loudbyte.com> wrote in message
news:076701c32f13$3a677a50$a501...@phx.gbl...

Chris H.

unread,
Jun 10, 2003, 2:13:44 AM6/10/03
to
Forgot to mention, the "Journal /RepairNoteWriter" is entered without the
quotes. 8-)

--
Chris H.
Microsoft Windows MVP/Tablet PC
Tablet PC Universe - www.tabletpcuniverse.net
Tablet PC Chat - http://thetabletpc.net/support.htm
Associate Expert
Expert Zone - www.microsoft.com/windowsxp/expertzone


"Chris H." <winx...@hotmail.com> wrote in message
news:OYVEucxL...@TK2MSFTNGP10.phx.gbl...

Dan Polivy [MS]

unread,
Jun 10, 2003, 11:06:07 AM6/10/03
to
Running "Journal /RepairNoteWriter" will only refresh the Journal Note
Writer printer driver files; it most likely won't help with this problem.
It sounds like something is up with either the inking components or Journal
itself.

There are a couple of things I would suggest, if the System Restore point
does not work.

Do other ink-enabled applications still work, i.e. InkBall, the TIP? If
not, you might try opening a command prompt to \Program
Files\Common\Microsoft Shared\Ink and running regsvr32 on the DLLs there.
At the command prompt, you would type "regsvr32 <filename.dll>" without the
quotes, where <filename.dll> is the filename of the DLL.

If that fails, try going to \Program Files\Windows Journal\ and running
regsvr32 on nbdoc.dll, inkseg.dll, mspvwctl.dll, and nbmaptip.dll.

Hopefully one of these will fix your problem. Please let me know if you
have any questions. :)

Dan

--

---
This posting is provided "AS IS" with no warranties, and confers no rights.


"Chris H." <winx...@hotmail.com> wrote in message

news:OSkSBex...@TK2MSFTNGP11.phx.gbl...

terri

unread,
Jun 10, 2003, 12:33:34 PM6/10/03
to
Hi, steve,

This is a compilation of a couple of posts from Sears Young at Microsoft.
Might be helpful if other things don't work.

Were changes made within the Regional and Language Options control panel
applet? I've seen this occur when installed services are removed/changed.
Can you try the following:

In Control Panel -> Regional and Language Options -> Languages tab ->
Details, under Installed services, verify that the following services are
present:

English (United States) <or the applicable localized language version>
Advanced Text Services
Tablet PC Correction
Tablet PC Correction for Windows Journal
Tablet PC Text Insertion

Note: If any of the services above are missing, use the Add button to
restore them (More text services option).

Tap the Advanced tab, and then verify the following:

The Extend support of advanced text services to all programs check box
is selected (checked).

The Turn off advanced text services check box is cleared (unchecked).

It may be necessary to restart your Tablet PC before the settings take
effect. Once restarted, try using the correction feature in Journal again.

If that doesn't work, then try the following -
If the steps in the article didn't work, then it could be that either some
of your Journal files have become corrupt/deleted, or possibly have become
unregistered. A couple of things that you might want to try:

1. Try logging in with a different user, and verify that it's a system-wide
issue, and not per user.
2. Manually re-register Windows Journal DLL's. To do that, do the
following

- Open a command prompt
- Change directory to <systemdrive>\Program Files\Windows Journal
- regsvr32 nbmaptip.dll
- Open a new instance of Journal and try converting handwriting to text.
- repeat for the other Journal DLL's in the folder if necessary (inkseg.dll,
jntfiltr.dll, mspvwctl.dll, and nbdoc.dll)

3. If possible, can you provide a list of applications you installed
between the time Journal worked correctly and stopped working?
4. Did you receive any crash/error dialogs between the time it last worked
and when you noticed it stop working?
5. Have you verified that you are running the latest version of the
drivers/utilities available for the Compaq TC1000?

--
Terri Stratton
Editor
http://thetabletpc.net
Now, chat - http://thetabletpc.net/support.htm
Microsoft MVP
Windows XP / Tablet PC


"steve" <st...@loudbyte.com> wrote in message
news:076701c32f13$3a677a50$a501...@phx.gbl...

jack

unread,
Jun 11, 2003, 11:48:31 AM6/11/03
to
I have encountered the exact same initialization problem
with Windows Journal. I tried system restore, but this
failed to fix the problem. I don't think it was any
software I installed otherwise, because after I
encountered this error I ghosted my computer (back to the
factory default). Journal worked for a while, and after a
few days started giving me the same error. I tried all
the fixes listed below and still recieve the same error.

>.
>

Reply all
Reply to author
Forward
0 new messages