[Excel2000] CONTA.SE con + condizioni

10 visualizzazioni
Passa al primo messaggio da leggere

Rik

da leggere,
2 lug 2002, 11:41:2202/07/02
a
Ciao,

qualcuno può spiegarmi la formula/sintassi corretta per la funzione
CONTA.SE o CONTA(SE(... considerando il contemporaneo verificarsi di
condizioni multiple.

Esempio banale:

A | B
1 X X
2 X Y
3 Y Y
4 Y X
5 X Y
6 Y X

qual'è quindi la sintassi per contare il numero di righe in cui
$A:$A="X" e (and) $B:$B="Y" che in questo esempio è = 2 ???

Grazie in anticipo per il prezioso aiuto. Rik

Lapalissiano

da leggere,
2 lug 2002, 12:51:5102/07/02
a
Il 2 Jul 2002 08:41:22 -0700, r.b...@savingroup.com (Rik) ha scritto:

>Ciao,
>
>qualcuno può spiegarmi la formula/sintassi corretta per la funzione
>CONTA.SE o CONTA(SE(... considerando il contemporaneo verificarsi di
>condizioni multiple.

>qual'è quindi la sintassi per contare il numero di righe in cui


>$A:$A="X" e (and) $B:$B="Y" che in questo esempio è = 2 ???

Credo che per fare questo devi usare una formula in forma di matrice. Il
modo piu' semplice che mi viene in mente e' usare una terza colonna dove
scriverai =E(A1="X";B1="Y") e cosi' via per poi contare i valori VERO.

--
Lapalissiano
Icq 57269703

fernando cinquegrani

da leggere,
2 lug 2002, 16:18:0102/07/02
a
"Lapalissiano" <lapali...@people.it> ha scritto nel messaggio
news:khl3iuoormfg90s5d...@4ax.com...

> Il 2 Jul 2002 08:41:22 -0700, r.b...@savingroup.com (Rik) ha scritto:
>
> >qualcuno può spiegarmi la formula/sintassi corretta per la funzione
> >CONTA.SE o CONTA(SE(... considerando il contemporaneo verificarsi di
> >condizioni multiple.

> Credo che per fare questo devi usare una formula in forma di matrice. Il


> modo piu' semplice che mi viene in mente e' usare una terza colonna dove
> scriverai =E(A1="X";B1="Y") e cosi' via per poi contare i valori VERO.

vedi anche
http://www.prodomosua.it/zips/sommase.xls
.f
http://www.prodomosua.it


Richard

da leggere,
3 lug 2002, 06:59:4203/07/02
a
"fernando cinquegrani" <f.cinq...@libero.it> ha scritto nel messaggio
news:ZTnU8.98486$Kt3.2...@twister2.libero.it...

grazie Fernando, molto bello il tuo sito, e la formula
(=SOMMA(($B$2:$B$17=B24)*($C$2:$C$17=C24)) funziona anche se sinceramente
non capisco la logica del CONTA che diventa SOMMA ?!?!

Adesso però ho degli altri problemi (es: con caratteri jolly) che penso
siano dovuti alle limitazioni della matrice:

la colonna A contiene un numeratore composto del tipo ###???#### e una delle
2 condizioni prevede che i primi 3 caratteri (numeri) di questo numeratore
siano = ad una cella fissa (negli esempi la B2).

ho provato sia così:

=SOMMA((SINISTRA($A$2:$A$10000;3)=B$2)*($D$2:$D$10000=$A48))

che così:

=SOMMA(($A$2:$A$10000=B$2&"???????")*($D$2:$D$10000=$A48))

(e in svariati altri modi senza successo)

in entrambi i modi il risultato = 0 quando invece non è vero. La formula
funziona, infatti sostituendo i caratteri jolly con caratteri presenti,
ottengo il risultato voluto.

AIUTO!!! Rik


fernando cinquegrani

da leggere,
3 lug 2002, 14:10:3503/07/02
a

"Richard" <r.b...@savingroup.com> ha scritto nel messaggio
news:upSakBoICHA.668@tkmsftngp09...

> "fernando cinquegrani" <f.cinq...@libero.it> ha scritto nel messaggio
> news:ZTnU8.98486$Kt3.2...@twister2.libero.it...
> >
> > vedi anche
> > http://www.prodomosua.it/zips/sommase.xls
> > .f
> > http://www.prodomosua.it
> >
>
> grazie Fernando, molto bello il tuo sito, e la formula
> (=SOMMA(($B$2:$B$17=B24)*($C$2:$C$17=C24)) funziona anche se sinceramente
> non capisco la logica del CONTA che diventa SOMMA ?!?!
>
> Adesso perň ho degli altri problemi (es: con caratteri jolly) che penso

> siano dovuti alle limitazioni della matrice:
>
> la colonna A contiene un numeratore composto del tipo ###???#### e una
delle
> 2 condizioni prevede che i primi 3 caratteri (numeri) di questo numeratore
> siano = ad una cella fissa (negli esempi la B2).
>
> ho provato sia cosě:
>
> =SOMMA((SINISTRA($A$2:$A$10000;3)=B$2)*($D$2:$D$10000=$A48))
>

questa formula č corretta e dovrebbe fornirti il risultato voluto.
si tratta di una forma matriciale quindi
devi inserire la formula non con <Invio>
ma con <Cntl><Maius><Invio>
.f
http://www.prodomosua.it

fernando cinquegrani

da leggere,
3 lug 2002, 15:24:5703/07/02
a
"Richard" <r.b...@savingroup.com> ha scritto nel messaggio
news:upSakBoICHA.668@tkmsftngp09...

> "fernando cinquegrani" <f.cinq...@libero.it> ha scritto nel messaggio
> news:ZTnU8.98486$Kt3.2...@twister2.libero.it...
> >
> > vedi anche
> > http://www.prodomosua.it/zips/sommase.xls
> > .f
> > http://www.prodomosua.it
> >
>
> grazie Fernando, molto bello il tuo sito, e la formula
> (=SOMMA(($B$2:$B$17=B24)*($C$2:$C$17=C24)) funziona anche se sinceramente
> non capisco la logica del CONTA che diventa SOMMA ?!?!
>

SOMMARE VERO+VERO+VERO
equivale a SOMMARE 1+1+1 che
equivale a CONTARE 1 e 1 e 1
.f
http://www.prodomosua.it

Rik

da leggere,
4 lug 2002, 03:12:5904/07/02
a

"fernando cinquegrani" <f.cinq...@libero.it> ha scritto nel messaggio
news:v6HU8.103153

> >
> > ho provato sia cosě:
> >
> > =SOMMA((SINISTRA($A$2:$A$10000;3)=B$2)*($D$2:$D$10000=$A48))
> >
>
> questa formula č corretta e dovrebbe fornirti il risultato voluto.
> si tratta di una forma matriciale quindi
> devi inserire la formula non con <Invio>
> ma con <Cntl><Maius><Invio>
> .f
> http://www.prodomosua.it
>
>

L'ho inserita correttamente in forma matriciale (ctrl+maisc+invio) ma
confermo che non da il risultato voluto in quanto sempre = 0.

Ciao. Rik


fernando cinquegrani

da leggere,
4 lug 2002, 18:52:3604/07/02
a
"Rik" <r.b...@savingroup.com> ha scritto nel messaggio
news:ugq2inyICHA.1744@tkmsftngp13...

ho aggiornato
http://www.prodomosua.it/zips/sommase.xls
nel foglio2 ti mostro
che la formula funziona
.f
http://www.prodomosua.it

Rispondi a tutti
Rispondi all'autore
Inoltra
0 nuovi messaggi