Verificare una formula

27 views
Skip to first unread message

Marco Porzio

unread,
Sep 6, 2021, 8:46:48 AMSep 6
to
ciao,
nel foglio 2 cella A1 ho questa formula:

=SE('Foglio1'!A1<>"";'Foglio1'!A1;"")

trascinando in giù ovviamente mi trascina i riferimenti quindi ad esempio alla riga 100 avrò:

=SE('Foglio1'!A100<>"";'Foglio1'!A100;"")

per qualche motivo però a volte mi perde il riferimento quindi fino a cella 99 è tutto ok poi invece di puntare alla cella 100 punta ad esempio alla cella 115 e da lì in poi prosegue con 116,117,118, ecc...

vorrei quindi poter verificare quando salta da una cella ad un'altra non consecutiva, si può fare in qualche modo?
magari nella colonna B mettere una formula che "Legge" il SE... e mi restituisce il numero di cella letta nella colonna A

grazie
Marco

Bruno Campanini

unread,
Sep 12, 2021, 7:07:35 AMSep 12
to
Marco Porzio hinking very hard :
Dal Foglio2 puoi leggere qualsiasi cella del Foglio1, scrivendo in una
cella di qualsiasi foglio: =Foglio1!Ax.

Ma non puoi modificare alcuna cella del Foglio1 partendo da una
qualsiasi cella di altro foglio.

Non so come funzioni in parte la formula che tu enunci: da me
(Win10, Office 2019, 64bit, ENG) non funziona in alcuna maniera.
L'unica via è quella di VBA.

Bruno

mau1791

unread,
Sep 12, 2021, 8:58:43 AMSep 12
to
Ciao Marco,
in merito a "> per qualche motivo però a volte mi perde il riferimento quindi fino a cella 99"è probabile che forse una qualche procedura in "Foglio1" riga 100 aggiunga 16 celle/righe e dunque i riferimenti sul "Foglio2" cambino.
Se vuoi mantenere "ancorati" i dati visualizzati in Foglio2 potresti (sempre in A1 del Foglio2) scrivere la formula:

=SE(SE.ERRORE(INDIRETTO("'"&"Foglio1'!A"& RIF.RIGA());"")=0;"";SE.ERRORE(INDIRETTO("'"&"Foglio1'!A"& RIF.RIGA());""))

Maurizio

Marco Porzio

unread,
Sep 13, 2021, 8:45:00 AMSep 13
to
ciao,
in realtà cercavo qualcosa di diverso... provo a spiegare meglio.

in foglio2 cella A7 ho questa formula:
=SE('Base dati'!A7<>"";'Base dati'!A7;"") dove base dati è il foglio da cui leggo

trascinando la cella in basso ovviamente avrò:
=SE('Base dati'!A8<>"";'Base dati'!A8;"")
=SE('Base dati'!A9<>"";'Base dati'!A9;"")
=SE('Base dati'!A10<>"";'Base dati'!A10;"")
...
...

come spiegato prima, a volte mi trovo che al posto di continuare con A11 se mi metto sulla cella vedo che la formula legge Ad esempio A15 ed è questo che voglio intercettare.
tieni conto che la formula =SE('Base dati'!A7<>"";'Base dati'!A7;"") l'ho messa in A7 del foglio 2 per cui volevo fare qualcosa di questo tipo:
se RIF.RIGA è <> da A7 contenuto nella formula allora scrivi X
dovrei leggere la formula, estrarre la cella (A7) e confrontarla con RIF.RIGA, se ho 7 e 7 tutto ok se ho 7 e 12 qualcosa non va e mi mette una X
non so se sia fattibile...
grazie
Marco




Reply all
Reply to author
Forward
0 new messages