Calcolare somme progressive di valori da tabella pivot

39 views
Skip to first unread message

Simone P.

unread,
Oct 7, 2021, 4:27:09 AM10/7/21
to
Buongiorno,
da un elenco di fatture con data, cliente, importo, etc, creo una tabella pivot con i mesi nelle righe e gli anni nelle colonne.

Ora, per esempio, vorrei calcolare la % del fatturato progressivo di un anno rispetto al precedente.
Utilizzando la formula:
INFO.DATI.TAB.PIVOT("IMPONIBILE FATTURA";$A$8;"MESE";"GENNAIO";"ANNO";"2021")/INFO.DATI.TAB.PIVOT("IMPONIBILE FATTURA";$A$8;"MESE";"GENNAIO";"ANNO";"2020")-1

ottengo il risultato per il mese di gennaio;
ora a febbraio io non vorrei il solo mese di febbraio ma "gennaio+febbraio" rispetto a "gennaio+febbraio" dell'altro anno e così via. Come posso fare?

grazie

Bruno Campanini

unread,
Oct 8, 2021, 7:13:47 AM10/8/21
to
It happens that Simone P. formulated :
Io ottengo il risultato con 30 righe di VBA.
Se t'interessa darci un'occhiata ti mando il file con un esempino.

Bruno

Simone P.

unread,
Oct 8, 2021, 8:55:45 AM10/8/21
to
Sicuramente potrei darci un'occhiata, ti ringrazio!

Simone

Bruno Campanini

unread,
Oct 8, 2021, 11:42:22 AM10/8/21
to
Simone P. laid this down on his screen :
https://1drv.ms/x/s!AvTaMfd5-b2o2kmlAKMwIB3M4m4G?e=Nwmzdq

Bruno

issdr

unread,
Oct 29, 2021, 11:00:04 PM10/29/21
to
riportare dividendo e divisore in colonne separate e poi utilizzarne una
terza per fare il lavoro? se fattibile la formula diventa banale.

Simone P.

unread,
Nov 3, 2021, 11:51:35 AM11/3/21
to
Il giorno sabato 30 ottobre 2021 alle 05:00:04 UTC+2 issdr ha scritto:
> riportare dividendo e divisore in colonne separate e poi utilizzarne una
> terza per fare il lavoro? se fattibile la formula diventa banale.

E' un ottimo rimedio perchè posso cambiare i filtri della pivot senza conseguenze, anche se replicare i dati appoggiandoli su altre colonne è qualcosa di "non lineare", ma comunque efficiente:

R10 =+INFO.DATI.TAB.PIVOT("IMPONIBILE FATTURA";$A$8;"MESE";"GENNAIO";"ANNO";R$9) **dove R9 è l'intestazione della colonna di appoggio che corrisponde all'anno - ESEMPIO 2020
R11 =+INFO.DATI.TAB.PIVOT("IMPONIBILE FATTURA";$A$8;"MESE";"FEBBRAIO";"ANNO";R$9) **dove R9 è l'intestazione della colonna di appoggio che corrisponde all'anno - ESEMPIO 2020
...
...

S10 =+INFO.DATI.TAB.PIVOT("IMPONIBILE FATTURA";$A$8;"MESE";"GENNAIO";"ANNO";S$9) **dove S9 è l'intestazione della colonna di appoggio che corrisponde all'anno - ESEMPIO 2021
S11 =+INFO.DATI.TAB.PIVOT("IMPONIBILE FATTURA";$A$8;"MESE";"FEBBRAIO";"ANNO";S$9) **dove S9 è l'intestazione della colonna di appoggio che corrisponde all'anno - ESEMPIO 2021
...
..

incidenza %:
T10: =SOMMA(S$10:S10)/SOMMA(R$10:R10)-1
T11: =SOMMA(S$10:S11)/SOMMA(R$10:R11)-1
...
..

Grazie!!

Reply all
Reply to author
Forward
0 new messages