Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.

IIS5.0 "Invalid Default Script Language"

Skip to first unread message


Mar 3, 2006, 11:00:38 AM3/3/06
Hi all,

I'm having problems with an IIS5.0 Server giving an "ASP 0201: Invalid
Default Script Language" error.

The error is occuring in a website created by an MSI (which has been used on
1,000 of servers already). It only occurs in the root of the website, it
does not affect virtual directories, only the root application.

Some things about the network and the issue:

* There are several web servers on the network, only one of them is affected
(therefore I'm ruling out a group policy issue, though I have checked that
logon as a service, logon as a batch job etc is set up correctly).
* The issue is intermittent. Sometimes the root application seems to work. I
haven't be able to work out how to make it work though!
* COM+ was reinstalled last week due to a problem with the COM+ catalog, the
IIS packages were recreated after the installation.
* The affected server is also a forest root domain controller, DNS Server
and DHCP Server.

Here are some of the thing's I've tried:

* I have tried changing the Default Scripting Language in the properties to
JScript, then back to VBScript.
* I have reinstalled Windows Script Engine (v5.6).
* I have checked that dlls are registered.
* I have checked registry and NTFS permissions for IIS, and on the root
* I have removed and recreated the web site.
* I have checked the metabase entries using MetaEdt32.

So, has anyone got any suggestions?



Jacqueline Jaynes [MSFT]

Mar 3, 2006, 11:18:44 AM3/3/06
This error is usually caused by lack of permissions. Check the following:

1. Make sure the Users group has Read/Execute permissions to the
\windows\system32\inetsrv folder and \inetpub\wwwroot and any other content
folders for your site.
2. Make sure the anonymous account(IUSR_machinename) has Read permissions
to the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Classes and all
3. Make sure the Users group has Read permissions on the following registry

Thank you,

Jackie Jaynes [MSFT]
Microsoft IIS

Please do not send email directly to this alias. This
is our online account name for newsgroup participation only.

This posting is provided "AS IS" with no warranties, and confers no rights.
You assume all risk for your use. © 2001 Microsoft Corporation. All rights


Mar 7, 2006, 11:22:21 AM3/7/06
That seems to have worked - thanks a lot for your help there!

"Jacqueline Jaynes [MSFT]" <> wrote in message

Jacqueline Jaynes [MSFT]

Mar 7, 2006, 3:39:47 PM3/7/06
Great! I'm glad to hear it is working now.
0 new messages