SMTP service hangs after IMF def update

86 views
Skip to first unread message

Ray Gibson

unread,
Jan 22, 2007, 3:45:41 PM1/22/07
to
Exchange 2003 sp2 using IMF. Windows 2003

Everytime I install the new Intelligent Message Filter Defs, the SMTP
service hangs. It will stop if I manually do it via the services.msc but it
takes a while.

When using WindowsUpdate to download and install the defs, it says that it
sucessfully installs but the SMTP never starts again. That is, until I
reboot. Rebooting starts the service like expected. Rebooting a Production
Server is no fun either!

My AV solution is exchange aware.

I've turned off the IMF in the properties of the virtual smtp server, but
that seems to have no effect on the slow stop and no starting
characteristics of the SMTP service. It displays:

"Could not start the Simple Mail Protocol (SMTP) service on local computer.
Error 1053. The service did not respond to the start or control request in
a timely fashion.

I want to be able to cycle the SMTP service without rebooting! Advice
please!

Thanks in advance,
Ray


Alexander Zammit

unread,
Jan 22, 2007, 4:48:38 PM1/22/07
to
IMF updates cause an IIS admin sevice restart.

This leads to restarting all IIS plug-ins including those from third parties
(many AV solutions integrate with Exchange in this manner).

The fact that you have problems with restarts indicates that most likely one
of these plug-ins is misbehaving.

So your task is that to identify who is causing this problem.
From what you say the problem does not seem to come from IMF.

I would try disabling the third party application and see if this problem is
"solved".

If yes then you need to contact support for the third party software.

--
Alexander Zammit
WinDeveloper Software
IMF Tune - Unleash the Full Intelligent Message Filter Power
http://www.windeveloper.com/imftune/


"Ray Gibson" <rayg...@nospamborsheims.com> wrote in message
news:e6%23vaWmP...@TK2MSFTNGP03.phx.gbl...

Ray Gibson

unread,
Jan 23, 2007, 9:38:46 AM1/23/07
to
thanks for the reply Alexander..

AV is Symantec for Exchange, and I do know that its an IIS plugin.. I don't
know why I didn't think of it!

I'll post back if/when I find it!


"Alexander Zammit" <alex@respond_to_group> wrote in message
news:uZe3U8mP...@TK2MSFTNGP03.phx.gbl...

Ray Gibson

unread,
Jan 23, 2007, 10:48:40 AM1/23/07
to
Stopping the Symantec Servies yeilds in a SMTP service that stops and starts
on a dime as expected!

thanks for the suggestion Alexander. I now have made some setting changes
in Symantec, and will test.


"Ray Gibson" <rayg...@nospamborsheims.com> wrote in message

news:evZB4uv...@TK2MSFTNGP03.phx.gbl...

men...@spotlightdesign.com

unread,
Mar 8, 2007, 12:32:09 PM3/8/07
to
I have the same problem on my 2003 server, I am not running symantec
AV, or any other plugsins I'm aware of (I am running blackberry BES
4.1, I don't know exactly how it integrates and if it counts as a
plugin)

the update to IMF runs automatically and sometimes (not every time)
the SMTP service will stop several seconds after being restarted at
the end of the update process.

starting the SMTP service fails.

if I restart the IISAdmin service first, then I could manually start
SMTP and it worked.

Mendel

On Jan 23, 10:48 am, "Ray Gibson" <raygib...@nospamborsheims.com>
wrote:
> Stopping the Symantec Servies yeilds in aSMTPservicethatstopsand starts


> on a dime as expected!
>
> thanks for the suggestion Alexander. I now have made some setting changes
> in Symantec, and will test.
>

> "Ray Gibson" <raygib...@nospamborsheims.com> wrote in message


>
> news:evZB4uv...@TK2MSFTNGP03.phx.gbl...
>
>
>
> > thanks for the reply Alexander..
>

> > AV is Symantec forExchange, and I do know that its an IIS plugin.. I


> > don't know why I didn't think of it!
>
> > I'll post back if/when I find it!
>
> > "Alexander Zammit" <alex@respond_to_group> wrote in message
> >news:uZe3U8mP...@TK2MSFTNGP03.phx.gbl...

> >>IMFupdates cause an IIS admin sevice restart.


>
> >> This leads to restarting all IIS plug-ins including those from third

> >> parties (many AV solutions integrate withExchangein this manner).


>
> >> The fact that you have problems with restarts indicates that most likely
> >> one of these plug-ins is misbehaving.
>
> >> So your task is that to identify who is causing this problem.
> >> From what you say the problem does not seem to come fromIMF.
>
> >> I would try disabling the third party application and see if this problem
> >> is "solved".
>
> >> If yes then you need to contact support for the third party software.
>
> >> --
> >> Alexander Zammit
> >> WinDeveloper Software

> >>IMFTune - Unleash the Full Intelligent MessageFilterPower
> >>http://www.windeveloper.com/imftune/
>
> >> "Ray Gibson" <raygib...@nospamborsheims.com> wrote in message
> >>news:e6%23vaWmP...@TK2MSFTNGP03.phx.gbl...
> >>>Exchange2003 sp2 usingIMF. Windows 2003


>
> >>> Everytime I install the new Intelligent MessageFilterDefs, theSMTP

> >>>servicehangs. It will stop if I manually do it via the services.msc


> >>> but it takes a while.
>
> >>> When using WindowsUpdate to download and install the defs, it says that

> >>> it sucessfully installs but theSMTPnever starts again. That is, until
> >>> I reboot. Rebooting starts theservicelike expected. Rebooting a


> >>> Production Server is no fun either!
>
> >>> My AV solution isexchangeaware.
>
> >>> I've turned off theIMFin the properties of the virtualsmtpserver,
> >>> but that seems to have no effect on the slow stop and no starting

> >>> characteristics of theSMTPservice. It displays:


>
> >>> "Could not start the Simple Mail Protocol (SMTP)serviceon local

> >>> computer. Error 1053. Theservicedid not respond to the start or


> >>> control request in a timely fashion.
>

> >>> I want to be able to cycle theSMTPservicewithout rebooting! Advice
> >>> please!
>
> >>> Thanks in advance,
> >>> Ray- Hide quoted text -
>
> - Show quoted text -


Reply all
Reply to author
Forward
0 new messages