Trouble with .resource in decompiled dll

5 views
Skip to first unread message

Pavel Kozhevnikov

unread,
Aug 27, 2020, 11:40:34 AM8/27/20
to
Hello!

I have one decompiled with ILSpy dll and now, when I load this library
compiled from the ILSpy sources, it throws an exception with this text:

"Could not find any resources appropriate for the specified culture or the
neutral culture. Make sure "CREngine.resource" was correctly embedded or
linked into assembly "CrystalDecisions.CrystalReports.Engine" at compile
time, or that all the satellite assemblies required are loadable and fully
signed."

I tried to add the resource file, which was decompiled from original dll,
to project resources, but nothing has changed.

Please, help me to resolve that issue. How can I troubleshoot the process
of resource lookup?

Anton Shepelev

unread,
Sep 1, 2020, 6:19:38 AM9/1/20
to
Pavel Kozhevnikov:

> I have one decompiled with ILSpy dll and now, when I load
> this library compiled from the ILSpy sources, it throws an
> exception with this text:
>
> "Could not find any resources appropriate for the
> specified culture or the neutral culture. Make sure
> "CREngine.resource" was correctly embedded or linked into
> assembly "CrystalDecisions.CrystalReports.Engine" at
> compile time, or that all the satellite assemblies
> required are loadable and fully signed."
>
> I tried to add the resource file, which was decompiled
> from original dll, to project resources, but nothing has
> changed.

All we had to do was include the resource correctly into the
project file. I wonder, though, why it did not work out of
the box, but that is a question for ILSpy maintainers.
Question closed.

--
() ascii ribbon campaign - against html e-mail
/\ http://preview.tinyurl.com/qcy6mjc [archived]
Reply all
Reply to author
Forward
0 new messages