link goes crazy in 2010 works fine in 2003

10 views
Skip to first unread message

sparks

unread,
Jul 31, 2013, 7:50:41 PM7/31/13
to
We have an older 2003 database with about 275 records.
The main table uses an autoid number called autoid and links to the
other tables that all have idnum some are one to one and some are one
to many. This database has never had a problem.
UNTIL you open it with access 2010. It pops up a box saying input
idnum.
No error or anything and I can't figure out what its looking at or
what its expecting or why.
Just for a quick test I ran compile and it doesn't show any errors but
you still get the box when you first open the main screen.

anyone got any ideas on how to track this down in 2010?

Gloops

unread,
Aug 1, 2013, 8:18:07 AM8/1/13
to
Hello,

I did not work with versions of Access more recent than 2007, but have a
certain experience of previous ones, including migrating from a version
to a newer.

You will get a better view if you can execute the form_load step by step
to see when an error appears (do not forget to put the error procedure
call in comments, and re-enable it when everything is ready), and copy
the SQL code of the form request, and paste it to the request editor to
launch it : the request editor often has much clearer messages than the
execution during a VB code or a macro.

A possible issue is that a default name has changed in the new version,
or that a prefix rule has changed (being said that for instance a field
name is prefixed by its table name).

At least, this will enable you to provide more information, that will
help to solve the problem.



AaronKempf.com | CareerDBA.com | FullStackWP.com

unread,
Jan 11, 2021, 5:51:34 AM1/11/21
to
it's just a mismatched fieldname. this is a feature not a bug.

I think that fmsinc has some tools that can help you find a particular fieldname, or query paramaeter.

but i'd just loop througth all the querydefs, write the .SQL to a table, and then look for the string that is popping up.

I mean seriously. I don't think that would take me 10 minutes.
Reply all
Reply to author
Forward
0 new messages