Bad news: my webcam doesn't work anymore

64 views
Skip to first unread message

Pablo Castellano

unread,
Aug 23, 2009, 8:24:13 PM8/23/09
to micr...@googlegroups.com
Hello.

I was a happy owner of a 0c45:6270 model. I was testing it in my recent
fresh install of Debian Lenny and it worked fine.

But now, it has automatically stopped working and when I plug it, this
is the output of dmesg:

[ 1323.636031] usb 1-9: new high speed USB device using ehci_hcd and
address 9
[ 1323.770673] usb 1-9: New USB device found, idVendor=0c45, idProduct=6270
[ 1323.770682] usb 1-9: New USB device strings: Mfr=0, Product=1,
SerialNumber=0
[ 1323.770688] usb 1-9: Product: USB20 Camera
[ 1323.770884] usb 1-9: configuration #1 chosen from 1 choice
[ 1323.771679] sn9c20x: SN9C20X USB 2.0 Webcam - 0C45:6270 plugged-in.
[ 1323.798792] sn9c20x: I2C slave 0x5d returned error during write to
address 0xff
[ 1323.799289] sn9c20x: I2C slave 0x5c returned error during write to
address 0x01
[ 1323.799786] sn9c20x: I2C slave 0x5d returned error during write to
address 0xf0
[ 1323.800285] sn9c20x: I2C slave 0x48 returned error during write to
address 0xf0
[ 1323.800291] sn9c20x: Unsupported sensor.
[ 1323.800320] sn9c20x: probe of 1-9:1.0 failed with error -22


Unsupported sensor!!??! What the h..
Does it mean that I have a bricked webcam? How could it happen? Is it
possible to unbrick it??
At the moment the only use of it seems to be used as flashlight...
:(

--
Regards, Pablo.

Brian Johnson

unread,
Aug 24, 2009, 1:15:46 AM8/24/09
to micr...@googlegroups.com
Seems to be failing the i2c register reads used for sensor probing
thus the undetected sensor. Are you using the same version of the
driver that worked with your camera before? and is is it the newest
version available from our git repository? Also if you can try it on a
windows computer if it doesn't work there then it probably is a
hardware issue with the camera. The particular error you are getting
is generated when the webcam's bridge report an error during i2c
communication with the sensor.

Brian Johnson

Pablo Castellano

unread,
Aug 24, 2009, 6:39:09 AM8/24/09
to micr...@googlegroups.com
Hi Brian.

I was using last git version when it worked and when it stopped working.

Before it stopped working I remember to have seen the "Unknown symbol
-1" error trying to reload sn9c02x (sudo make rmmod && sudo make
insmod). I did make clean and make all, and then the module loaded well
but it was not working.

I also have tried it on Windows and I get a completely black screen and
sometimes a white one. (Well, to be honest I had never used it in
Windows before, so there's a remote possibility that the driver I have
found for it isn't correct at all...)

If I understand well, you say that the problem is the module cannot read
some specific register to guess the sensor model and then it says my
sensor is unsupported... is there any way to force it specifying which
model I have?

I can supply all the useful debug information that you may need.

Thanks for your interest.

--
Regards, Pablo.

Brian Johnson

unread,
Aug 24, 2009, 3:27:03 PM8/24/09
to micr...@googlegroups.com
Forcing a model won't help because if the driver is unable to
communicate with the sensor over any of the valid i2c addresses used
by your camera even if you forced it to use a particular sensor it
still would not be able to talk to communicate with said sensor.
Seeing as how windows also seems to be failing to work correctly my
guess is that there actually is something wrong with your camera and
in that case i'm not really sure there is much you can do about. If
you want you could try the new gspca version of the driver that is
part of the v4l-dvb repository att linuxtv.org, but if the microdia
driver and the windows drivers are both not working correctly the gspc
version probably won't help either.


Brian Johnson

Pablo Castellano

unread,
Aug 25, 2009, 3:07:11 PM8/25/09
to micr...@googlegroups.com
Hello again, Brian.

I understand... but well, I will try another day with the new version of gspca
as you said. I didn't know that driver and if I get something interesting
I'll come back to this mailing list to inform you.

I don't have still clear why did it happen.
Do you think that it happened because the webcam was faulty? (It was cheap
so I cannot expect the components inside are of the best quality).
Or otherwise it happened because of this driver (sn9c20x) that maybe did
something wrong at the low level with registers?
Is there any other reason?

Thanks.

--
Regards, Pablo Castellano.

Reply all
Reply to author
Forward
0 new messages