blue screen output for mplayer

39 views
Skip to first unread message

Claudio Miranda

unread,
May 17, 2009, 3:28:10 PM5/17/09
to microdia
Hi folks,

Some months ago, before microdia module was renamed to sn9c20x, the my
webcam worked very nice (mplayer, skype, shots).
Then I had the good idea to update my microdia git copy, built and
installed, but it doesn't work
Launched mplayer, it displays a blue scree, see
http://microdia.googlegroups.com/web/mplayer-webcam-shot1.png

My webcam
Bus 005 Device 017: ID 0c45:6270 Microdia U-CAM PC Camera NE878

I have update my local microdia copy this afternoon
$ git pull

And have loaded the modules as this

sudo modprobe videodev
sudo insmod ./sn9c20x.ko

There were no sn9c20x or microdia modules loaded before.

Linux version
$ uname -a
Linux foxhound 2.6.24-22-generic #1 SMP Mon Nov 24 18:32:42 UTC 2008
i686 GNU/Linux

Configure v4l2

$ export LD_PRELOAD=/usr/local/lib/libv4l/v4l2convert.so
$ ls -l /usr/local/lib/libv4l/v4l2convert.so
-rwxr-xr-x 1 claudio claudio 13K 2009-04-30 00:42 /usr/local/lib/
libv4l/v4l2convert.so*

The v4l library as compiled and installed on 04/30

launch mplayer

$ mplayer tv:// -tv driver=v4l2:width=640:fps=25:height=480:device=/
dev/video0

See the output below. Can you help me make this work ?

Thanks !

MPlayer 1.0rc2-4.2.4 (C) 2000-2007 MPlayer Team
CPU: Genuine Intel(R) CPU T2400 @ 1.83GHz (Family: 6,
Model: 14, Stepping: 8)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote
control.

Playing tv://.
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <olsch...@zpr.uni-koeln.de>
comment: first try, more to come ;-)
Selected device: SN9C20x USB 2.0 Webcam Driver
Capabilites: video capture read/write streaming
supported norms:
inputs: 0 = Webcam;v4l2: ioctl get input failed: Invalid argument

Current input: 1
Current format: unknown (0x30323953)
tv.c: norm_from_string(pal): Bogus norm parameter, setting default.
v4l2: ioctl enum norm failed: Invalid argument
Error: Cannot set norm!
Selected input hasn't got a tuner!
v4l2: ioctl set mute failed: Invalid argument
xscreensaver_disable: Could not find XScreenSaver window.
==========================================================================
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 640 x 480 (preferred colorspace: Planar
YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 640x480 => 640x480 Planar YV12
Selected video codec: [rawyv12] vfm: raw (RAW YV12)
==========================================================================
Audio: no sound
Starting playback...
No bind found for key 'c'.
V: 0.0 39/ 39 ??% ??% ??,?% 0 0


Claudio Miranda

unread,
May 27, 2009, 11:59:11 PM5/27/09
to microdia
Hey guys, sorry to bore you, but do can you help me ?

Thanks

Claudio

On May 17, 4:28 pm, Claudio Miranda <clau...@claudius.com.br> wrote:
> Hi folks,
>
> Some months ago, before microdia module was renamed to sn9c20x, the my
> webcam worked very nice (mplayer, skype, shots).
> Then I had the good idea to update my microdia git copy, built and
> installed, but it doesn't work
> Launched mplayer, it displays a blue scree, seehttp://microdia.googlegroups.com/web/mplayer-webcam-shot1.png
>  author: Martin Olschewski <olschew...@zpr.uni-koeln.de>

GWater

unread,
May 28, 2009, 3:56:52 AM5/28/09
to microdia
I'm sorry no one answered before.

There's one more thing you can do:
Try the whole mplayer thing again and afterwards post the output of
$ dmesg | grep sn9c20x

Hopefully this will give me an idea of where the problem could be.

GWater

Joseph Olstad

unread,
May 28, 2009, 9:35:41 AM5/28/09
to microdia
Claudio, did you try loading MPlayer like this?

Try this command instead
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so mplayer tv:// -tv
driver=v4l2:width=640:height=480:fps=25:device=/dev/video0 -vo x11

See if that makes a difference. I did this and it worked with the new
sn9c20x the first time I tested it , I also tested with skype using
the LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype
and video in Skype worked for me as well (sound with skype was another
story though).

HOWEVER, now I have a new problem, for some reason, the driver was
loaded, now it doesn't seem to be loaded anymore after I ran insmod
once , tested ok first time I ran it, then several days later
attempted to use the webcam again but I can't now, says /dev/video0
doesn't exist and I get an error inserting the kernel module. I tried
recompiling and inserting again. It appears that I need to run
insmod after I reboot? If so, what are the potential issues that
could come up there? I am using Ubuntu 9.04 , how do I make the kernel
module come back up after rebooting automatically? Or is it some
other issue like a temp file that is locked in /tmp or something ? (I
didn't try cleaning the /tmp folder yet)

Here is output from dmesg | tail
$ dmesg|tail
[10161.472157] ath5k phy0: noise floor calibration failed (2412MHz)
[10161.580170] ath5k phy0: noise floor calibration failed (2417MHz)
[10281.472188] ath5k phy0: noise floor calibration failed (2412MHz)
[10281.576168] ath5k phy0: noise floor calibration failed (2417MHz)
[11552.798806] sn9c20x: Unknown symbol video_ioctl2
[11552.800383] sn9c20x: Unknown symbol video_devdata
[11552.801942] sn9c20x: Unknown symbol video_unregister_device
[11552.802367] sn9c20x: Unknown symbol video_device_alloc
[11552.802586] sn9c20x: Unknown symbol video_register_device
[11552.803665] sn9c20x: Unknown symbol video_device_release


and from "sudo insmod sn9c20x.ko"
$ sudo insmod sn9c20x.ko
[sudo] password for joe:
insmod: error inserting 'sn9c20x.ko': -1 Unknown symbol in module

I'll have to review the installation procedure again and try it again,
but perhaps there's something else going on. How can I automatically
have this kernel module load every time I start my notebook computer
with Ubuntu 9.04?

Thanks for the assistance.

Josua Grawitter

unread,
May 28, 2009, 2:07:44 PM5/28/09
to micr...@googlegroups.com
> --~--~---------~--~----~------------~-------~--~----~
> Lets make microdia webcams plug'n play, (currently plug'n pray)
> To post to this group, send email to micr...@googlegroups.com
> Visit us online https://groups.google.com/group/microdia
> -~----------~----~----~----~------~----~------~--~---

All you need is "videodev":
# modprobe videodev

GWater

signature.asc

Gijs Hillenius

unread,
May 29, 2009, 12:29:23 AM5/29/09
to micr...@googlegroups.com, micr...@googlegroups.com

On 28 mei 2009, at 20:07, Josua Grawitter <grew...@googlemail.com>
wrote:

> All you need is "videodev":
> # modprobe videodev

And if that works, add these modules to /etc/modules ..

echo "videodev >> /etc/modules"
Repeat for the other modules.

Joseph Olstad

unread,
May 29, 2009, 3:41:38 PM5/29/09
to microdia
Thanks GWater and Gijs ,

I figured it out thanks to your suggestions.

Just had to

sudo modprobe videodev
sudo insmod ./sn9c20x.ko


then to automate this to remain loaded on future reboots, I will try
what Gijs suggested and if I have problems I'll let you know

echo "videodev >> /etc/modules"
Repeat for the other modules.

Thanks,

Skype is working using my webcam, MPlayer using webcam works like
this, as long as I use the ldconfig parameters mentioned in this
thread.

Thanks again


On May 29, 12:29 am, Gijs Hillenius <gijs.hillen...@gmail.com> wrote:
> On 28 mei 2009, at 20:07, Josua Grawitter <grewa...@googlemail.com>  
> >> Visit us onlinehttps://groups.google.com/group/

Claudio Miranda

unread,
May 31, 2009, 11:11:03 AM5/31/09
to microdia

Hi GWater, thank for the reply, see the output

$ dmesg | grep sn9c20x
[ 244.453421] sn9c20x: SN9C20X USB 2.0 Webcam - 0C45:6270 plugged-in.
[ 244.472261] sn9c20x: I2C slave 0x5d returned error during write to
address 0xff
[ 244.564715] sn9c20x: Detected MT9V111 Sensor.
[ 244.564770] sn9c20x: Webcam device 0C45:6270 is now controlling
video device /dev/video0
[ 244.626720] sn9c20x: Using yuv420 output format
[ 244.626754] usbcore: registered new interface driver sn9c20x
[ 244.626757] sn9c20x: SN9C20x USB 2.0 Webcam Driver v2009.04 loaded
[ 449.259341] sn9c20x: [E] Empty buffer queue.


I typed the command, as Olstad suggested, but unfortunately the result
was the same as my original post.

Do you think a strace would be useful ?

Thanks for your time and assistance.

Claudio Miranda

Brian Johnson

unread,
Jun 3, 2009, 11:52:55 PM6/3/09
to micr...@googlegroups.com
Claudiio,
Can you try loading the module with debug loggin turned on

# sudo rmmod sn9c20x
# sudo insmod ./sn9c20x.ko log_level=15

Then after running mplayer the dmesg log should have much more
information about what our driver is doing

Claudio Miranda

unread,
Jun 11, 2009, 12:58:19 AM6/11/09
to microdia
Hi Brian, thanks for the help

I uploaded the log files to the files section
http://microdia.googlegroups.com/web/microdia-debug-dmesg.log.gz

Brian Johnson

unread,
Jun 11, 2009, 2:09:02 PM6/11/09
to micr...@googlegroups.com
Claudio,
After looking over the log files it certainly seems as if things
should be working fine and i'm not seeing anything that looks wrong.
Have you tried any other programs besides mplayer? als try running
mplayer like

# export LD_PRELOAD=/usr/local/lib/libv4l/v4l2convert.so
# mplayer tv:// -tv
driver=v4l2:width=640:height=480:fps=25:device=/dev/video0 -vo jpeg

This should make mplayer generate a series of jpeg images. If you ope
n them do you see a good image or are they ll just blue as well?

Claudio Miranda

unread,
Jun 15, 2009, 11:27:09 PM6/15/09
to microdia
Hi Brian, setting the output to jpeg worked !

I will try to make it work with other output settings and see if it
works.

Thanks a lot !

Claudio Miranda
Reply all
Reply to author
Forward
0 new messages