Error on gem install merb on UbuntuServer 10.04 x64

5 views
Skip to first unread message

Kurtosis

unread,
Aug 15, 2010, 12:12:16 AM8/15/10
to merb
I'm new to merb and am setting it up on a VM - UbuntuServer on
VirtualBox, but am getting the following error when trying to install
merb:

> sudo apt-get install ruby1.9.1-full rubygems1.9.1
(success, no errors)
> sudo gem install merb
ERROR: Error installing merb
bundler requires RubyGems version >= 1.3.6
> gem -v
1.3.5

1.9.1 is the latest version available in the Ubuntu repository.
Suggestions?

Kai Chen

unread,
Aug 15, 2010, 1:08:13 AM8/15/10
to me...@googlegroups.com
Try rvm:

http://rvm.beginrescueend.com/

--
Regards,
Kai Chen (陈恺)

> --
> You received this message because you are subscribed to the Google Groups "merb" group.
> To post to this group, send email to me...@googlegroups.com.
> To unsubscribe from this group, send email to merb+uns...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/merb?hl=en.
>
>

Joshua Timberman

unread,
Aug 15, 2010, 1:19:06 AM8/15/10
to me...@googlegroups.com
Hello!

Two issues.

RubyGems version has nothing to do with the version of Ruby.

Via inheriting the package from Debian, Ubuntu's RubyGems is broken by
design because you cannot use the gem update --system to upgrade the
RubyGems version when it is installed from package (and for other
reasons irrelevant to this discussion).

Generally, I install RubyGems from source on Ubuntu systems. However,
since some Rubyists have said 1.9.1 has its own problems, 1.9.2 is
recommended. The suggestion of rvm is probably the best bet, and you
would definitely want to use RubyGems from source there.

--
Joshua Timberman
http://twitter.com/jtimberman

Rajesh Malepati

unread,
Aug 15, 2010, 8:59:34 AM8/15/10
to me...@googlegroups.com
On Sun, Aug 15, 2010 at 10:49 AM, Joshua Timberman <jos...@housepub.org> wrote:
> Hello!
>
> On Sat, Aug 14, 2010 at 10:12 PM, Kurtosis <fbg...@gmail.com> wrote:
>> I'm new to merb and am setting it up on a VM - UbuntuServer on
>> VirtualBox, but am getting the following error when trying to install
>> merb:
>>
>>> sudo apt-get install ruby1.9.1-full rubygems1.9.1
>> (success, no errors)
>>> sudo gem install merb
>> ERROR:  Error installing merb
>>              bundler requires RubyGems version >= 1.3.6
>>> gem -v
>> 1.3.5
>>
>> 1.9.1 is the latest version available in the Ubuntu repository.
>> Suggestions?
>
> Two issues.
>
> RubyGems version has nothing to do with the version of Ruby.
>
> Via inheriting the package from Debian, Ubuntu's RubyGems is broken by
> design because you cannot use the gem update --system to upgrade the
> RubyGems version when it is installed from package (and for other
> reasons irrelevant to this discussion).
>

This is not Ubuntu/Debian problem. RubyGems is broken by design.

Joshua Timberman

unread,
Aug 15, 2010, 12:06:32 PM8/15/10
to me...@googlegroups.com
On Sun, Aug 15, 2010 at 6:59 AM, Rajesh Malepati <chit...@gmail.com> wrote:
> This is not Ubuntu/Debian problem. RubyGems is broken by design.

That `gem update --system` doesn't work when installing the RubyGems
package on Debian/Ubuntu?

No, that is specifically a packaging decision taken by the rubygems
package maintainer. That command works on OS X and RubyGems installed
from source just fine.

Rajesh Malepati

unread,
Aug 15, 2010, 12:24:12 PM8/15/10
to me...@googlegroups.com

gem update --system shouldn't exist. And the Debian guys did the right thing.

Joshua Timberman

unread,
Aug 17, 2010, 11:15:21 AM8/17/10
to me...@googlegroups.com
On Aug 15, 2010, at 10:24 AM, Rajesh Malepati wrote:

> gem update --system shouldn't exist. And the Debian guys did the right thing.


Why? Isn't that the preferred method for updating RubyGems?

% gem help update
Usage: gem update GEMNAME [GEMNAME ...] [options]

Options:
--system Update the RubyGems system software
...

My understanding, after being involved with Ruby projects for the last three years is that installing RubyGems from source, and updating it with the above is the preference. Generally speaking, binary distributions lag behind upstream versions; this is nothing new.

For example, RHEL 6 has Ruby 1.8.6: ruby-1.8.6.383-6.1.el6.x86_64.rpm

pedro mg

unread,
Aug 17, 2010, 11:27:53 AM8/17/10
to me...@googlegroups.com
Hi,

There is a script to allow it. Try this:

$ sudo gem install rubygems-update
$ sudo update_rubygems

best regards,
pedro mg
http://blog.tquadrado.com

Reply all
Reply to author
Forward
0 new messages