Processing XWinNMR data

36 views
Skip to first unread message

Mark

unread,
Oct 12, 2017, 12:08:23 PM10/12/17
to mddnmr
Hello,

I'm trying to process a fully-sampled HSQC experiment using qMDD (v2.5). The spectrum was recorded as a fully sampled experiment using XwinNMR. If I try and open this using the qMDD Gui I get the error:
'Cannot determine TOPSPIN version'

Is there a way round this to be able to use the GUI with XwinNMR data?

Many thanks,

Mark


Vladislav Orekhov

unread,
Oct 12, 2017, 12:19:00 PM10/12/17
to mdd...@googlegroups.com
Hi Mark,
qMDD is only a GUI.
The simplest is to use as template a .proc directory with all files from another  similar full 2D HSQC experiment recorded with TopSpin.
You only need to edit fidSP.com and proc.sh script files. Info for fidSP.com you find using  command "bruker"  from nmrPipe package. In proc.sh you only need to edit the experiment number.
Then, you run qMDD, select the experiment and answer "no" to overwrite files in .proc dir.
I hope it will work.

Regards,
Vladislav
--
--
You received this message because you are subscribed to the Google Groups "mddnmr" group.
To post to this group, send email to mdd...@googlegroups.com rom your registered email address.
To unsubscribe from this group, send email to mddnmr-un...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/mddnmr

---
You received this message because you are subscribed to the Google Groups "mddnmr" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mddnmr+un...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Mark

unread,
Oct 13, 2017, 5:05:26 AM10/13/17
to mddnmr
Dear Vladislav,

Thanks for your reply. I had tried setting up a .proc directory with files fidSP.com, nls.hdr_3, nls.in, proc.sh and recFT.com. However, if I run the qMDD GUI all the options are greyed out and the only thing I can click on is the 'Open spectrum' button. If I point this at the Bruker data folder I get the error 'Cannot determine TOPSPIN version' and if I point it at the .proc directory I get the error 'no fid/ser file found'. I have also tried putting the .proc directory inside the Bruker data directory (rather than at the same level) and get the 'TOPSPIN' error again.

I realise that you can run this just as a script-based programme, however, as I am very unfamiliar with the options I am not sure I am setting things up correctly. At the moment, if I run proc.sh I get the error:

Warning: CEXP corrected: new yn old nn
########## conversion from spectrometer format to nmrPipe format ../102 to ./XYZA/ft4sp.xyza.2D
Pipe streem (XYZA) ./XYZA/ft4sp.xyza.2D is ready
Error ReadInFidData: unexpected end of data in ./XYZA/ft4sp.xyza.2D 65792 of 131584
  For Bruker data try to ZF to a defined size with -fn ZF -size ...

mddnmr4pipeN 1 2 3 4 5 failed

(In fidSP.com and recFT.com I have nmrPipe -fn ZF -size set already.)

I was also trying to using the example 2D gNhsqc_S for comparison. If I run the GUI here I get the error:

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
agilent spectrum 'gNhsqc_S' opened OK
Traceback (most recent call last):
  File "~/qMDD/mddnmr/GUI/qMDDGUI.py", line 346, in specOpen
    self.procPrep()
  File "~/qMDD/mddnmr/GUI/qMDDGUI.py", line 360, in procPrep
    overwrite=qMDD.prepareProc(str(self.specDir.dirName()),self.specName,self.specType,self.topspinVersion,self.uiparams)
  File "~/qMDD/mddnmr/GUI/qMDD.py", line 248, in prepareProc
    fid.readfid()
  File "~/qMDD/mddnmr/GUI/qMDDlib.py", line 135, in readfid
    self.fid = np.rec.fromfile(self.fidFile, dtype = self.fhc, offset = self.off)
  File "~/miniconda3/envs/py27/lib/python2.7/site-packages/numpy/core/records.py", line 780, in fromfile
    _array = recarray(shape, descr)
  File "~/miniconda3/envs/py27/lib/python2.7/site-packages/numpy/core/records.py", line 419, in __new__
    self = ndarray.__new__(subtype, shape, (record, descr), order=order)
TypeError: 'numpy.float64' object cannot be interpreted as an index

I'm not sure if this error is due to some incompatibility with my python version (I am using Anaconda python 2.7) or some setting in that dataset.

Many thanks for your help,

Best wishes,

Mark
Reply all
Reply to author
Forward
0 new messages