Issue 194 in maven-alfresco-archetypes: mvn install not woking, resource oss-parent-3.pom moved

27 views
Skip to first unread message

maven-alfres...@googlecode.com

unread,
Aug 26, 2014, 5:30:52 AM8/26/14
to maven-a...@googlegroups.com
Status: New
Owner: ----
Labels: Type-Defect Priority-Medium

New issue 194 by j...@weitan.org: mvn install not woking, resource
oss-parent-3.pom moved
https://code.google.com/p/maven-alfresco-archetypes/issues/detail?id=194

What steps will reproduce the problem?
1.
Follow this tutorial:
http://ecmarchitect.com/alfresco-developer-series-tutorials/maven-sdk/tutorial/tutorial.html

2.
It will break at the step: "Let's run it"

cd someco-mvn-tutorial-repo
mvn integration-test -Pamp-to-war


3.
It seems one resource has moved, the first entry in the stacktrace:

Caused by: org.apache.maven.project.InvalidProjectModelException: Not a
v4.0.0 POM. for project org.sonatype.oss:oss-parent at
/root/.m2/repository/org/sonatype/oss/oss-parent/3/oss-parent-3.pom

The url for this resource seems to be moved somewhere else:

# cat /root/.m2/repository/org/sonatype/oss/oss-parent/3/oss-parent-3.pom

<html>
<head><title>301 Moved Permanently</title></head>
<body bgcolor="white">
<center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx</center>
</body>
</html>




Details I did:

2:
https://artifacts.alfresco.com/nexus/content/groups/public/archetype-catalog.xml
-> org.alfresco.maven.archetype:alfresco-allinone-archetype (Sample
multi-module project for All-in-One development on the Alfresco plaftorm.
Includes modules for: Repository, AMP, Share, Solr, Web Quick Start and
embedded Jetty run)
Choose a number or apply filter (format: [groupId:]artifactId, case
sensitive contains): : 1
Choose org.alfresco.maven.archetype:alfresco-amp-archetype version:
1: 1.0
2: 1.0.1
3: 1.0.2
4: 1.1.0
5: 1.1.1
Choose a number: 5: 5
Define value for property 'groupId': : com.someco
Define value for property 'artifactId': : someco-mvn-tutorial-repo



Maybe I can fix this locally.

Thanks for any hint.




--
You received this message because this project is configured to send all
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings
Reply all
Reply to author
Forward
0 new messages