Dataset Update not working

11 views
Skip to first unread message

Marius

unread,
Sep 27, 2018, 2:28:28 AM9/27/18
to MapTiler Community
Hi there,

I'm having trouble updating a vector tileset.

Steps to reprodruce:
1. click on the dataset
2. click the upload button
3. upload the updated mbtiles files
4. success message appears and I get redirected
5. dataset is still the same, no update visible (even after 1 day of waiting)

what do I do wrong? How can i update an existing vector tileset without deleting an recreating it?
thanks!

Marius

Marius

unread,
Sep 27, 2018, 2:31:39 AM9/27/18
to MapTiler Community
addition:
dataset details state
"Last modified 2018-09-27 06:25"
(it was 8:25 in my local time UTC+1)

Marius

unread,
Sep 27, 2018, 3:19:33 AM9/27/18
to MapTiler Community
addition #2:
I see the update in the corresponding map which incorporates the dataset, but still not in the dataset viewer. so this is probably a caching issue.

MapTiler

unread,
Sep 27, 2018, 3:56:23 AM9/27/18
to MapTiler User Group
Hi Marius,

I passed this over to our development team and their answer is:

Upload was successful. For raster tiles, there is a cache but should be updated in terms of hours. You should probably check if you upload the correct file.


Best regards,
Martin
--
MapTiler Team
Twitter: @klokantech


On Thu, Sep 27, 2018 at 9:19 AM Marius <tag...@gmail.com> wrote:
addition #2:
I see the update in the corresponding map which incorporates the dataset, but still not in the dataset viewer. so this is probably a caching issue.

--
You received this message because you are subscribed to the Google Groups "MapTiler Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to maptiler+u...@googlegroups.com.
To post to this group, send email to mapt...@googlegroups.com.
Visit this group at https://groups.google.com/group/maptiler.
For more options, visit https://groups.google.com/d/optout.

Marius

unread,
Sep 27, 2018, 9:52:50 AM9/27/18
to MapTiler Community
Thanks!

By now the dataset has been updated in the dataset viewer. So it has worked and was the correct file but there definitely was some kind of cache in the vector dataset viewer. Probably on the client side/browser because as far as i could see, the urls of the json and pbf files have no version parameter or the like, so maybe the browser displays it from the cache although a newer version is available on the server.
Reply all
Reply to author
Forward
0 new messages