Mapstore2 Installation on Tomcat

159 views
Skip to first unread message

Joel Divekar

unread,
Nov 22, 2021, 12:48:35 AM11/22/21
to mapstore-users
Hi All.

I am new to mapstore2 and trying to install it on a freshly deployed Rocky 8.x server. I have installed Tomcat and tried to deploy mapstore.war file from tomcat interface but it is not working. And when I checked the mapstore.logs, I see this error. Please can someone guide me or help we me with tomcat installation.

INFO   2021-11-20 11:05:33.112   SessionFactoryImpl.<init>() - building session factory 
INFO   2021-11-20 11:05:33.399   SessionFactoryObjectFactory.addInstance() - Not binding factory to JNDI, no JNDI name configured 
INFO   2021-11-20 11:05:33.402   SchemaUpdate.execute() - Running hbm2ddl schema update 
INFO   2021-11-20 11:05:33.402   SchemaUpdate.execute() - fetching database metadata 
ERROR   2021-11-20 11:05:34.733   SchemaUpdate.execute() - could not get database metadata 
org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Error while creating file "/webapps" [90062-168])
        at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:1225)
        at org.apache.commons.dbcp.BasicDataSource.getConnection(BasicDataSource.java:880)
        at org.hibernate.ejb.connection.InjectedDataSourceConnectionProvider.getConnection(InjectedDataSourceConnectionProvider.java:47)
        at org.hibernate.tool.hbm2ddl.SuppliedConnectionProviderConnectionHelper.prepare(SuppliedConnectionProviderConnectionHelper.java:27)
        at org.hibernate.tool.hbm2ddl.SchemaUpdate.execute(SchemaUpdate.java:127)
        at org.hibernate.impl.SessionFactoryImpl.<init>(SessionFactoryImpl.java:314)
        at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1300)
        at org.hibernate.cfg.AnnotationConfiguration.buildSessionFactory(AnnotationConfiguration.java:859)
        at org.hibernate.ejb.Ejb3Configuration.buildEntityManagerFactory(Ejb3Configuration.java:669)
        at org.hibernate.ejb.HibernatePersistence.createContainerEntityManagerFactory(HibernatePersistence.java:132)
        at org.springframework.orm.jpa.LocalContainerEntityManagerFactoryBean.createNativeEntityManagerFactory(LocalContainerEntityManagerFactoryBean.java:225)
:

Regards

Joel

Joel Divekar

unread,
Nov 22, 2021, 2:13:03 AM11/22/21
to mapstore-users
Sorry missed version details

# java -cp catalina.jar org.apache.catalina.util.ServerInfo
Server version: Apache Tomcat/9.0.54
Server built:   Sep 28 2021 13:51:49 UTC
Server number:  9.0.54.0
OS Name:        Linux
OS Version:     4.18.0-348.2.1.el8_5.x86_64
Architecture:   amd64
JVM Version:    1.8.0_312-b07
JVM Vendor:     Red Hat, Inc.

Manoj Bisht

unread,
Sep 21, 2022, 3:18:07 PM9/21/22
to mapstore-users
Have u solved this problem then please share the same.

Manoj Bisht

unread,
Sep 21, 2022, 3:57:33 PM9/21/22
to mapstore-users

ok it has been resolved

Jure G

unread,
Dec 9, 2022, 4:26:39 PM12/9/22
to mapstore-users

Dear All

I have the same issue with deploying Mapstore war on Tomcat 9 (Centos 7 inside of Oracle VM Vbox 7.0).

Tried with different java OpenJDK versions (8, 11), changing ownership of folders, different mapstore releases but result is always the same.

Mapstore won't start and log file shows the same errors (see the attachment).


If there is a known solution please let me know how to solve this issue.


Thanks in advance,

Jure


sreda, 21. september 2022 ob 21:57:33 UTC+2 je oseba er.bish...@gmail.com napisala:
mapstore.log

Jure G

unread,
Dec 12, 2022, 1:59:06 AM12/12/22
to mapstor...@googlegroups.com
I have solved the issue with creating Geostore in PostgreSQL and configuring Mapstore to use  it as described in Mapstore user documentation.

Br,
Jure

V pet., 9. dec. 2022 22:26 je oseba Jure G <jur...@gmail.com> napisala:
--
You received this message because you are subscribed to the Google Groups "mapstore-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mapstore-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mapstore-users/8cdc4ea4-398d-41f7-a32b-691ee09bd459n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages