Portofino 5 on Synology - MariaDB connection

26 views
Skip to first unread message

Alex Avron

unread,
Jun 3, 2020, 11:46:41 AM6/3/20
to manydesigns-portofino
Hi,

I managed to install Tomcat, and portofino in my synology NAS.
I can load the page and I'm stuck at the wizard.

When I enter my DB credentials (login, password, url, etc...) I get a message saying: "org.mariadb.jdbc.Driver". and nothing else.
I could not find the MariaDB log on my synology, and have no idea why I cannot connect.
(I have another tool running, PHP based, connecting to that database and working well).

Thanks for your help

Java 8
Tomcat 7
PHP 5.6
MariaDB 10
on Synology DS218J

Alessio Stalla

unread,
Jun 3, 2020, 12:19:40 PM6/3/20
to manydesign...@googlegroups.com
Hi,

you may want to look into the Tomcat logs. Did you add the MariaDB driver to the Tomcat libraries? Also, Portofino 5 requires Tomcat >= 8, if I remember correctly.

--
You received this message because you are subscribed to the Google Groups "manydesigns-portofino" group.
To unsubscribe from this group and stop receiving emails from it, send an email to manydesigns-port...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/manydesigns-portofino/ca34669f-f946-4cf4-8d1c-da1e798e8452%40googlegroups.com.

Alex Avron

unread,
Jun 3, 2020, 5:09:39 PM6/3/20
to manydesigns-portofino
Thanks for the prompt reply. It's working fine now !
I reinstalled Tomcat 8 (not supplied as a standard package by synology. I had to SSH everything...)
It still did not work.
And also made sure to have the right mariaDB driver, and made sure to restart the server. I think it was not in the right directory, and that's why it did not work.

All fine. I'm now playing with it and trying to set everything up.

Alex

Le mercredi 3 juin 2020 18:19:40 UTC+2, Alessio Stalla a écrit :
Hi,

you may want to look into the Tomcat logs. Did you add the MariaDB driver to the Tomcat libraries? Also, Portofino 5 requires Tomcat >= 8, if I remember correctly.

On Wed, 3 Jun 2020 at 17:46, Alex Avron <al...@pntpower.com> wrote:
Hi,

I managed to install Tomcat, and portofino in my synology NAS.
I can load the page and I'm stuck at the wizard.

When I enter my DB credentials (login, password, url, etc...) I get a message saying: "org.mariadb.jdbc.Driver". and nothing else.
I could not find the MariaDB log on my synology, and have no idea why I cannot connect.
(I have another tool running, PHP based, connecting to that database and working well).

Thanks for your help

Java 8
Tomcat 7
PHP 5.6
MariaDB 10
on Synology DS218J

--
You received this message because you are subscribed to the Google Groups "manydesigns-portofino" group.
To unsubscribe from this group and stop receiving emails from it, send an email to manydesigns-portofino+unsub...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages