Import Projects

13 views
Skip to first unread message

Gabriel Silva Fiorese

unread,
Jul 30, 2015, 11:51:59 PM7/30/15
to Malhar
Hello DataTorrent Community, I am new to DataTorrent and am evaluating it for my company. Already I read a lot of documentation and am now trying to import the projects into Eclipse in order to be able to take a look on how to proceed in the development . My problem is that when importing projects have the following error information :
Project build error: Non-resolvable parent POM for com.datatorrent:malhar:2.2.0-SNAPSHOT: Failure to transfer com.datatorrent:dt-framework:pom:2.2.0-SNAPSHOT from 
 https://www.datatorrent.com/maven/content/repositories/releases/ was cached in the local repository, resolution will not be reattempted until the update interval of datatorrent 
 has elapsed or updates are forced. Original error: Could not transfer artifact com.datatorrent:dt-framework:pom:2.2.0-SNAPSHOT from/to datatorrent (https://
 www.datatorrent.com/maven/content/repositories/releases/): www.datatorrent.com and 'parent.relativePath' points at wrong local POM

Can anybody help me?

Thanks.

Thomas Weise

unread,
Jul 31, 2015, 12:51:33 AM7/31/15
to malhar...@googlegroups.com
Hi Gabriel,

You are building the master branch, which depends on the snapshot version of Apex: https://github.com/DataTorrent/Apex
 
You can build that Apex version on your local machine, so that your local maven repository can supply the missing artifacts.

I would recommend however that you start with a released Malhar version instead (release branch): https://github.com/DataTorrent/Malhar/tree/release-3.0

Thomas
 

--
You received this message because you are subscribed to the Google Groups "Malhar" group.
To unsubscribe from this group and stop receiving emails from it, send an email to malhar-users...@googlegroups.com.
To post to this group, send email to malhar...@googlegroups.com.
Visit this group at http://groups.google.com/group/malhar-users.
For more options, visit https://groups.google.com/d/optout.

MOOLAMREDDY SIDDA REDDY 15MCB1013

unread,
Sep 22, 2016, 5:36:59 AM9/22/16
to Malhar - Deprecated-Use-Apache-Apex-Forums
hello sir
iam getting an error while configuring the hadoop location can you please help me 
Screenshot from 2016-09-22 14:48:03.png

MOOLAMREDDY SIDDA REDDY 15MCB1013

unread,
Sep 22, 2016, 5:38:29 AM9/22/16
to Malhar - Deprecated-Use-Apache-Apex-Forums
can you please resolve the error attached in image
Screenshot from 2016-09-22 14:48:03.png
Reply all
Reply to author
Forward
0 new messages