No power to Mobo

5 views
Skip to first unread message

Joe Allen

unread,
Apr 3, 2010, 5:35:25 PM4/3/10
to MakerBot Operators
I am having enough of a problem with this that I thought I'd ask for
help in a new thread. I haven't seen anyone else with this problem,
but I'm hoping it's an easy fix that I am just overlooking.
So, I got my 'bot the other day, and spent several happy hours putting
it all together. Problem is, now it won't power up! The power supply
switch and the switch on the motherboard are both "on", but the
"power" LED does not light up, and RepG says there is nothing in the
com port (which makes sense, since it has no power). I have tested
the power supply, and it works. Which of course, makes me think there
is something wrong with the board. In theory, the board must have
worked when the MakerBot folks loaded the bootloader and firmware, so
what could have changed between then and when I installed the board?
I can't see any obvious loose connections or solder bridge-type
shorts, and I don't know what else to check. Any ideas?
I feel like Dr Frankenstein, and my little plywood monster is just
lying there on the table. Help bring my creature life! Thanks.
-Joe

Jason Evanko

unread,
Apr 3, 2010, 6:22:08 PM4/3/10
to make...@googlegroups.com
I had same issue with mine, which turned out to be a faulty on/off
switch. So I just put a piece of extra wire in- between the metal
plate and contact on the inside of the switch, on the "on" side which
seemed to work until I could replace it. I don't know if you checked
this but it's worth a shot if you didn't.
Hope this helps
-Jason

> --
> You received this message because you are subscribed to the Google
> Groups "MakerBot Operators" group.
> To post to this group, send email to make...@googlegroups.com.
> To unsubscribe from this group, send email to makerbot+u...@googlegroups.com
> .
> For more options, visit this group at http://groups.google.com/group/makerbot?hl=en
> .
>

Joe Allen

unread,
Apr 3, 2010, 6:36:58 PM4/3/10
to MakerBot Operators
I hope it is something that simple, but my switch seems to be fine.

On Apr 3, 3:22 pm, Jason Evanko <samidge...@gmail.com> wrote:
> I had same issue with mine, which turned out to be a faulty on/off  
> switch. So I just put a piece of extra wire in- between the metal  
> plate and contact on the inside of the switch, on the "on" side which  
> seemed to work until I could replace it. I don't know if you checked  
> this but it's worth a shot if you didn't.
> Hope this helps
> -Jason
>

Roboteernat

unread,
Apr 3, 2010, 7:11:55 PM4/3/10
to MakerBot Operators
Have you got access to a multimeter, may be worth checking your
getiting voltage to the board. check te switch to see if the voltage
is comming through there, if it isnt, then its your psu or wiring from
said psu, if it is then its the board.
let us know if ur getting voltages

Joe Allen

unread,
Apr 3, 2010, 8:29:08 PM4/3/10
to MakerBot Operators
Hmmm. You are right, Nat. 0.0V at the switch. As you say, this means
it's gotta be the PSU. And yet when I tested that (by jumping pins 14
&15, and the fan came on), it seems to be working too. Guess I'll
check all the connections. Don't have another PSU handy, or I would
just swap it out.

Joe Allen

unread,
Apr 3, 2010, 9:22:14 PM4/3/10
to MakerBot Operators
Ahh, a flicker of hope (maybe). As I was removing the power plug for
the Nth time to try another PSU that I scrounged up, I accidentally
left the power on, and as I removed the plug, the "power" LED
flickered for a second. If I wiggle the plug around in the socket, I
get repeated flickers, but not with any consistency to isolate where
the loose connection might be. The solders under the plug all look OK,
as I mentioned before, so is there some other way to test these to see
which one might be shorting? I don't know enough about what all the
20 pins do, or the circuitry of the mobo, to figure it out myself at
the moment. So frustrating to have to QA a PCB that I've been waiting
2 months for. Thanks for the help, gang. This group is great.

Lyndondr

unread,
Apr 3, 2010, 9:43:18 PM4/3/10
to MakerBot Operators
If you have a soldering iron take and remelt all the joints on that
connector. Also make sure all the wires in the power supply connector
are in place not being pushed out (do that first).

Joe Allen

unread,
Apr 3, 2010, 10:11:19 PM4/3/10
to MakerBot Operators
I get the same result with both PSUs, so it is definitely an issue
with the board. I don't mind doing a little soldering, but I was
hoping for a more systematic way to test what exactly is going on. My
soldering skills are ok, but I'd be a little afraid of messing things
up more, and possibly for no reason. Of course, at this point, I'll do
a rain dance if it gets the bot running :-) Here I was, all worried
about the intricacies of skeinforge, and I can't even get the power
on, lol.

JohnWasser

unread,
Apr 4, 2010, 11:10:58 AM4/4/10
to MakerBot Operators
On Apr 3, 10:11 pm, Joe Allen <flatiron...@gmail.com> wrote:
> I was hoping for a more systematic way to test what exactly is going on.

If you don't want to re-solder every pin, examine each solder
connection under magnification and look for any that are not shiny or
where the solder is cracked or where the solder does not merge
seamlessly with the pin and circuit trace.

If all look good, examine the other power components on the board.
Download the schematic and copper patterns to see what is connected
where.

Joe Allen

unread,
Apr 4, 2010, 2:21:39 PM4/4/10
to MakerBot Operators
Well, as I said above, the solder joints look pretty solid (http://
www.flickr.com/photos/flatironjoe/4490475314/), and they all test fine
with a meter. And yet my problem persists, so obviously I'm missing
something. I am a bit frustrated to have to start looking up
schematics and troubleshooting a board that should just work out of
the box. It must have functioned ok when they uploaded the bootloader
and firmwear at MBI - unless they decided to purposely send me a
faulty board, which would be silly. I think the folks at MakerBot are
selling a great product at an incredible price, but you'd think they
would have this down by now. I know it's a kit, so I am prepared to
be responsible for any faults I introduce when I put it together, and
to do some minor tweaking. But when the parts themselves are not
functional, I don't see how that makes it my responsibility to become
an electrical engineer. I am asking MakerBot for a new board. These
are, of course, out of stock, so I will probably have to wait another
month (or two) before I can get my bot to be anything more than a
$1000 paperweight. Grrrr.

ps- I realize I am just that unlucky 1% (or whatever the fail rate
is), so I shouldn't complain so much, but thus far, my makerbot
experience has been nothing but frustration. i'll quit my bitching
now.

Jason Evanko

unread,
Apr 4, 2010, 3:21:04 PM4/4/10
to make...@googlegroups.com
It might be a connection issue between the board and the powersupply
with the connector pins. You said that when you wiggled the connector
out the power led flickered a little. So maybe one of the pins on the
psu's part of the connector doesn't have good contact. I'm fairly new
to this as well but just thought I'd throw my two cents in.

-Jason

Lyndondr

unread,
Apr 4, 2010, 3:59:16 PM4/4/10
to MakerBot Operators
It doesn't really matter how they look if it's not working and the
power flickers when you plug it in. Something in those joints or in
the area are connecting when the board is flexed when it's plugging
in. Also check the 30 ohm resistor? If that has a bad connection the
power supply may refuse to turn on without a load on the 5v line.
Refer to the link below but the mother board is not powered to burn
the boot loader so the board was never powered to program. I have seen
solder joints that look good but were not. If you have solder wick
remove some of the solder and add some flux and re-solder the atx and
resistor joints.

http://www.reprap.org/wiki/Motherboard_1.2

On Apr 4, 1:21 pm, Joe Allen <flatiron...@gmail.com> wrote:
> Well, as I said above, the solder joints look pretty solid (http://www.flickr.com/photos/flatironjoe/4490475314/), and they all test fine

Joe Allen

unread,
Apr 4, 2010, 4:49:06 PM4/4/10
to MakerBot Operators
Thanks for the continued help, guys.
Jason- I get the same results with another power supply, so that
really points to the board being the weak link.
Lyndondr- You are right. No matter the appearance, something in that
area is not connecting properly. I tried re-heating those solder
joints (your first suggestion), and now am able to get the flicker to
last longer, if I hold the connector just right. I will try wicking
them all out and re-soldering the whole thing. I thought about the
30ohm resistor as well, but based on the last results, it really does
seem like an issue with the atx connector. You are also correct about
the board not being powered to program the bootloader, but it should
need to be to upload the firmwear, no?

Lyndondr

unread,
Apr 4, 2010, 5:27:53 PM4/4/10
to MakerBot Operators
Yes from what I know the board needs power for firmware updates. It
comes with the firmware preloaded. Good to hear a little progress.

Steven Dick

unread,
Apr 4, 2010, 6:04:09 PM4/4/10
to make...@googlegroups.com
Is it the board or the power connector itself that has a bad connection?

Joe Allen

unread,
Apr 4, 2010, 6:20:27 PM4/4/10
to MakerBot Operators
Steven- The connector is just pins soldered to the board, with a
plastic shell around them, so I'm not sure what the distinction would
be. Or maybe I'm not understanding your question.

Joe Allen

unread,
Apr 4, 2010, 8:25:50 PM4/4/10
to MakerBot Operators
OK, the weirdness continues. No change with the connector, even after
re-soldering all 20 pins (and re-soldering the 30ohm resister, just in
case). I can still get the power to stay on if I hold the psu
connector just so, but not if I plug it all the way in. With power
off, and connector fully seated, I get continuity between all 20 PSU
cables and the pins on the back side of the board. This seems like a
contradiction. If all the connections are being made, why doesn't the
power come on? Could there be a problem elsewhere on the board that
would lead to this behavior?
Also, while I had it propped up so the power would stay on, I tried
connecting it to the x-axis driver and my pc, to see if the rest of
the board works and I might be able to control it with RepG. But as
soon as I plug in the TTL2USB cable, the power cuts out. Unplug it,
it comes back on. Anyone with a better knowledge of circuitry,
particularly this board, have any other suggestions?

Joe Allen

unread,
Apr 4, 2010, 10:38:01 PM4/4/10
to MakerBot Operators
Okay, I am nothing if not persistent. Since my last results seemed to
indicate the power would come on when there _wasn't_ a good
connection, I made 20 jumpers and connected them all from the end of
the psu cable to the connector on the mobo. Proceeded to remove each
one in turn, and voila! Power came on when pin 9 was disconnected (all
others still plugged in). Connecting the TTL2USB still shut it back
off. According to the schematic, Pin 9 connects to the 5VSB. On the
bottom of the board, it's trace connects all over the place, which
makes sense if it's supplying the 5V power. There must be a short
somewhere else that is bypassed when this pin isn't connected. Still
have no idea where the actual problem is, but it ain't the atx
connector. Sorry to keep going on about this, and I hope no one ever
has this same problem, but I would very much like to get to the bottom
of this so I can start complaining about plastic blobs and skeinforge
settings instead :-)

Andrew Plumb

unread,
Apr 4, 2010, 11:21:42 PM4/4/10
to make...@googlegroups.com
Four follow-up questions then:

1. Is the USB2TTL cable plugged in the right way around? (just checking! :-)

2. Is this the MakerBot-supplied USB2TTL or some other converter?

3. Without the USB end plugged into your computer (aka unpowered), does plugging the serial end into the motherboard also make it shut down? (it shouldn't)

4. How does the extruder board behave if you plug the USB2TTL cable into its serial port?

Just in case, take some photos of the serial port area of the motherboard. Might be something else strange/shorted in that part of the board.

Andrew.

> --
> You received this message because you are subscribed to the Google Groups "MakerBot Operators" group.
> To post to this group, send email to make...@googlegroups.com.
> To unsubscribe from this group, send email to makerbot+u...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/makerbot?hl=en.
>

--

"The future is already here. It's just not very evenly distributed" -- William Gibson

Me: http://clothbot.com/wiki/

Joe Allen

unread,
Apr 4, 2010, 11:48:17 PM4/4/10
to MakerBot Operators
Andrew-
1. Yep :-) I was wondering the first time I plugged it in, then
finally saw the tiny writing on the board.
2. It's the cable from MakerBot that came with my kit
3. Correct. When the USB end is not plugged in, it has no effect.
4. When I plug the USB to the computer and attach to the extruder, it
powers up, and also lights LED4 and LED8

I added some shots (on flikr) of the serial end on the board. Looks
pretty clean to me, but what do I know?
Thanks for sharing some brainpower.

> > For more options, visit this group athttp://groups.google.com/group/makerbot?hl=en.

Andrew Plumb

unread,
Apr 5, 2010, 9:52:05 AM4/5/10
to make...@googlegroups.com
Hey Joe,

Nothing jumps out at me as being wrong in the connector area: http://www.flickr.com/photos/flatironjoe/4491687455/

A longer shot: Pin 4 of the USB2TTL is RXD, which is connected to pin 9 of the ATMEGA644A, which is adjacent to the crystal pin 8 (XTAL2).

With your multimeter and the motherboard completely disconnected, do you see/measure any shorts between any USB2TTL connector pins and the crystal's pins? Access the crystal leads from the bottom of the board with one probe and rake the USB2TTL with the other.

I don't have a board in front of me to confirm this (anyone else?), but I wouldn't expect to see any connections. If you do there could be a solder bridge between those pins on the ATMEGA644A.

Andrew.

> For more options, visit this group at http://groups.google.com/group/makerbot?hl=en.

Joe Allen

unread,
Apr 5, 2010, 11:35:00 AM4/5/10
to MakerBot Operators
Andrew- No shorts between the crystal and the serial port. I broke
out my magnifying loop last night and scanned the whole board for
solder bridges, light solder joints, etc, and the ATMEGA chip looks
good from what I can see. The only suspect spot on the board was in
the area between the ATX connector and the SD card slot. There is a
group of 6 resistors there, which all look fine, but there are also
about 7 vias in the board, some of which are filled, some are not, and
a couple look sort of half-filled. The traces get too small in there
for me to follow the circuit to tell which ones should be filled and
which shouldn't. I know it's not part of the USB/TTL circuit, but
could this be the culprit? Can anyone look and see which should be
filled? It would be nice if this could be fixed by adding or removing
a tiny dab of solder.

JohnWasser

unread,
Apr 5, 2010, 12:19:44 PM4/5/10
to MakerBot Operators
The vias should be plated through. The solder in the vias should be
more a matter of "don't care".

Re-soldering the power connector is STILL your best bet.

Joe Allen

unread,
Apr 5, 2010, 5:48:28 PM4/5/10
to MakerBot Operators
John, I did already re-solder it (twice), and the results are the
same. And I think my other tests have pretty well demonstrated the
problem is not a failure in the connnector. In fact, the power only
comes on when pin 9 *does not* connect (see posts above). That's why
I would get a flash of power when the connection was wiggled, but
never when it was fully seated (and therefor fully connected). There
is a problem somewhere else on the board, and this problem is bypassed
when pin 9 (the 5V power) wasn't connected. Still don't know where
"somewhere else" is though.

I don't know much about PCB design, so I'm a little confused by your
comment about the vias. Why would some get filled and others not if
the solder doesn't matter? It may have nothing to do with my current
issue, but you made me curious.

Anybody got any other ideas for things to check?
MakerBot says they are also surprised, and they are sending me a new
motherboard. Assuming that one is functional, I'll do a visual
comparison of the two before I send this one back for them to analyze
and return to the manufacturer. I'm mostly interested in having a
functioning Cupcake, but I am still very eager to figure out what the
heck is going on with this bad mother(board).

> > > Me:http://clothbot.com/wiki/- Hide quoted text -
>
> - Show quoted text -

Joe Allen

unread,
Apr 11, 2010, 12:33:47 PM4/11/10
to MakerBot Operators
New board from MakerBot arrived yesterday, and it plugged in an worked
straight away, like it should! The other one was definitely a dud.
Not sure what the problem was, but I'm sending it back to MakerBot,
and maybe one of the folks there who knows a lot more about
electronics than I do can figure it out. (For the record, all 7 of
those vias are filled in on the new board, so maybe that was it??)
Thanks so much to everyone who helped me in my attempts to
troubleshoot.

Hurray, my Cupcake lives! Now if only I can get it to start extruding
properly... :-)

> > > > Me:http://clothbot.com/wiki/-Hide quoted text -

Reply all
Reply to author
Forward
0 new messages