installation issue with HDF5 libraries

101 views
Skip to first unread message

Matteo Zanovello

unread,
Aug 15, 2023, 12:15:34 PM8/15/23
to Biociphers
Dear Biociphers team,

I'm trying to install Majiq on our cluster - Rocks 7.0 (Manzanita)

I'm not able to install Majiq, because of the following error:

error: Unable to load dependency HDF5, make sure HDF5 is installed properly

error: libhdf5.so: cannot open shared object file: No such file or director

Failed to build h5py

ERROR: Could not build wheels for h5py, which is required to install pyproject.toml-based projects


I've installed all the required packages, including python (3.11), HDF5 (1.14), GCC 4.8.5, htslib (1.18)

I've tried to change LD_LIBRARY_PATH but I still cannot install it. Any hint on why?


Bests

Matteo

San Jewell

unread,
Aug 21, 2023, 2:45:15 PM8/21/23
to Biociphers
Hi Matteo,

I'm not too familiar with Rocks myself, but on a cursory search it looks like it's based on CentOS/RedHat. You are missing the hdf5 development libraries / headers in this machine. After enabling epel, this library can usually be installed with:

# yum install hdf5-devel

Please let me know if you've tried to install this package, if it solves your issue.

Thanks,
-San

Matteo Zanovello

unread,
Aug 22, 2023, 6:28:16 AM8/22/23
to Biociphers
Hi San,

Thanks for your help.
Unfortunately, I don't have root permission but I eventually managed to install it by manually installing HDF5 for CentOS 7.x from the developer (I think I previously installed a wrong version).


Thanks again,
Matteo

Reply all
Reply to author
Forward
0 new messages