Failed Installation

29 views
Skip to first unread message

joshy45266

unread,
Aug 2, 2021, 12:53:55 PMAug 2
to majiq_voila
I am currently attempting to install Majiq and Voila on my Mac OS. I am using Anaconda Navigator and adding the commands through the terminal. I have attached the output error to this email and added a list of the installed packages. I am new to using any type of programming language. I hope I gave you enough information to assist me with the install.

It would also be helpful to know if I should be using something other than Anaconda Navigator. Is the something better that I could be using?

Any help would be greatly appreciated.
Majiq&Voila_Installation Fail.docx
Installed Packages_Majiq.docx

Paul Jewell

unread,
Sep 10, 2021, 10:34:28 AMSep 10
to majiq_voila
Hello,

The specific error leads to "Something's broken.  UCHAR_MAX should be defined in limits.h." -- This appears to be an issue with the C compiler on your machine: https://stackoverflow.com/questions/52550241/trying-to-install-anything-with-pip-on-macos-and-cannot  -- Personally, I've not used anaconda navigator. I would recommend, as a first installation, using the official instructions provided when registering for the software (registering multiple times if needed is fine). This involves using python3.8 venv and possibly needing to install HTSLIB. If we can see that the basic installation works, then maybe we could more on to troubleshooting anaconda navigator. Would you be able to give this a shot?

Thanks!
Reply all
Reply to author
Forward
0 new messages