MS mailbox problems after Mac crashing.

4 views
Skip to first unread message

Den Dowling

unread,
Oct 10, 2018, 4:24:10 PM10/10/18
to Mailsmith-Talk List
Hi all,
I’m looking for a little help with a Mailsmith problem.
I'm on MS 2.4.3 and Sierra 10.12.6 on MacBook Pro Retina Late 2013.

My mac has been having some hardware problem causing
occasional unexpected shutdowns. So, I’ve been trying to keep
MS closed when not in use. But, there have been a couple crashes
with MS open.

Since yesterday I have a problem with Mailsmith where some
mailboxes do not show any messages, just blank lines, even
though there is a large mailbox message count.

Sending mail works fine. And, new messages are arriving OK
in the (incoming mail) box but, not being filtered out to the
mailboxes with blank message lists.

error pop-up when clicking some mailboxes:
“A structural defect was found in this database (bad
object version). Please contact <sup...@mailsmith.org> for
assistance (application error code: 20474)”

Mailsmith error message box has many 20474 errors:
“An error occurred while processing the message
“[ANN] BBEdit 12.5 (411031) pre-release”.
A structural defect was found in this database (bad
object version). Please contact <sup...@mailsmith.org> for
assistance (Application error code 20474).”

I tried to do mailbox rebuilds, which worked OK on a small
mailbox but, did not work on a larger box with ~7000+ messages.

I have a Time Machine backup from Oct.5 that I could try to
revert too. And, it looks like I could probably export any
messages since then from my incoming box.

Does anyone have any suggestions for a fix besides
resorting to the backup?

Thanks, - Den.
MailsmithProblem.jpg

Jeroen Scheerder

unread,
Oct 11, 2018, 3:24:20 AM10/11/18
to Mailsmith-Talk List
Quoth Den Dowling (10 Oct 2018, 22:24):

> I tried to do mailbox rebuilds, which worked OK on a small mailbox but, did not work on a larger box with ~7000+ messages.
>
> I have a Time Machine backup from Oct.5 that I could try to revert too. And, it looks like I could probably export any messages since then from my incoming box.
>
> Does anyone have any suggestions for a fix besides resorting to the backup?

Do you perhaps have access to a stable Mac? If so, you could copy your damaged ~/Mail/Mailsmith User Data over and try to rebuild there and see what happens. If that doesn't work either, restoring a known good recent backup would probably be the best option.
signature.asc

Den Dowling

unread,
Oct 11, 2018, 7:14:56 AM10/11/18
to mailsmi...@googlegroups.com
Thanks Jeroen. I got my Time Machine backup for MS running
fine. Just had to export a few sent messages from the corrupt
version and import those to the clean backup.

Basically, I was just wondering if rebuilding mailboxes is
the only option for correcting faulty list display and/or
corrupt message database or, is there some other fix to try.

Thanks, - Den.


10/11/18 12:24 AM, j...@xs4all.nl (Jeroen Scheerder) apparently typed:
Reply all
Reply to author
Forward
0 new messages