Error by fipsld command with libcrypto configured with "no-dso" option

7 views
Skip to first unread message

sudhir n

unread,
Apr 1, 2021, 6:25:24 AM4/1/21
to
We are seeing following command failing, specifically with the libcrypto (here it is libvxcrypto), which is built with configure time option "no-dso".

Any known limitation that fipsld doesnt supports libcrypto built with configure time option "no-dso"?


+ fips/fipsld -fPIC -DOPENSSL_PIC -DOPENSSL_THREADS -D_REENTRANT -m64 -DL_ENDIAN -DTERMIO -O3 -Wall -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_MONT5 -DOPENSSL_BN_ASM_GF2m -I<path>/include -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DAES_ASM -DVPAES_ASM -DBSAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM -DECP_NISTZ256_ASM .//vxpsp-version.o -m64 -shared -Wl,-Bsymbolic -Wl,-soname=libvxcrypto.so.7 -o libvxcrypto.so.7 -Wl,--whole-archive libvxcryptoS.a -Wl,--no-whole-archive -L. -ldl

>>>
48009554138152:error:2507006C:DSO support routines:DSO_load:functionality not supported:dso_lib.c:229:
Reply all
Reply to author
Forward
0 new messages