Mailsearch won't work

17 views
Skip to first unread message

Stephan Schaffner

unread,
Jun 21, 2022, 11:06:00 AM6/21/22
to MailArchiva
Hello everybody,

I just installed an on-prem version of mailchiva, connected it with my Office365 and almost everything works fine after importing. But when I go to seach mails on my main account, I receive an error: 

Cannot parse 'anyaddress:%email%': too many boolean values

On my other mail accounts I can acces the mail search. Does anybody has a idea what I could do so find out whats wrong?

Thanks!

Cheers
Stephan

Jamie

unread,
Jun 22, 2022, 2:47:01 AM6/22/22
to MailArchiva
Stephan

Thank you for getting in touch. In regards to your concern, how many emails do you have associated with your main Office 365 account? It seems in your case, there are too many such that the limit on the number of boolean operators in a Lucene query is exceeded. To get it to work, you could edit your administrator role and empty out the view filter. For us to be able to debug this issue, please enable troubleshoot logging in COnfiguration->Logs, reproduce the problem and send us your debug.log file to support at mailarchiva.com

Stephan Schaffner

unread,
Jun 22, 2022, 3:59:33 AM6/22/22
to MailArchiva
Hey Jamie,

what exactly do you mean then? You mean aliases I set on the account, or shared Mailboxes? Well I got three shared Mailboxes assigned, but 120 aliases. :) Maybe thats the issue 😅
debug.log

Jamie

unread,
Jun 22, 2022, 4:25:05 AM6/22/22
to MailArchiva
Yeah, you simply have too many aliases. Lucene cant deal with that amount. You either need to pare them down, or create a special role for yourself with a custom viewfilter.
Reply all
Reply to author
Forward
0 new messages