IO.pipe in Maglev

18 views
Skip to first unread message

Jonathan Mason

unread,
Jun 3, 2013, 7:44:27 PM6/3/13
to MagLev Discussion
Hey all,

So I'm working on getting Puma up and running under Maglev. I ran into an issue where they are using IO.pipe for some inter-thread communication. 

IO.pipe doesn't seem to exist in Maglev. Anyone have any insite into why that is or how hard it would be to add?

cheers,
jem

Richard Sargent

unread,
Jun 4, 2013, 12:42:13 PM6/4/13
to maglev-d...@googlegroups.com
I see the HPI guys just did a build this morning with IO.pipe now defined.
(It looks like it wasn't hard to add at all.)



--
You received this message because you are subscribed to the Google Groups "MagLev Discussion" group.
To unsubscribe from this group and stop receiving emails from it, send an email to maglev-discuss...@googlegroups.com.
To post to this group, send email to maglev-d...@googlegroups.com.
Visit this group at http://groups.google.com/group/maglev-discussion?hl=en-US.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

Jonathan Mason

unread,
Jun 5, 2013, 1:08:28 PM6/5/13
to MagLev Discussion
Hello all,

The HPI guys do seem to have added IO.pipe! Well done guys.

For my next trick, I will point out that Puma uses IO.select on IO.pipe ends.

I made a Github issue for it this time and tried to put all the relevant info in there. Let me know if there anything you guys can do about this or need anymore information from me.
Reply all
Reply to author
Forward
0 new messages