Problem with memory in Flash MX 2004

Skip to first unread message


Apr 5, 2004, 4:39:57 AM4/5/04
My operating system is Windows XP. I cannot open a flash file that i've worked
on for quite some time. It used to open fine, yet in the last couple hours,
Flash cannot open the file and says that more memory must be allocated. I
don't know how to allocate more memory to the program. I've also tried closing
all my programs in the taskbar, I ran virus scanning software (nothing came
up), deleted other files to make memory available, defragmented my computer,
restarted my computer, and ran Flash in safe mode: NOTHING WORKS. I have the
newest version of Flash MX 2004 with the update, and this problem still
happened. Is there anything else I could do? I really dont wanna throw away
this flash file i've been working on for weeks on end. Help will be greatly
appreciated. Thanks.


Apr 5, 2004, 10:00:30 AM4/5/04
How much RAM does your system have?

"HVnitro006" <> wrote in message


Apr 5, 2004, 3:06:42 PM4/5/04
512 MB of RAM


Apr 5, 2004, 4:27:19 PM4/5/04
If you have added some video or large images to your Fla file, this might be
what is causing your problem.
If you are not planning to upgrade your RAM, perform a system Help search
for "allocate memory" (minus the quotes), windows has clear directions about
how to increase your systems virtual memory on the hard-drive.


"HVnitro006" <> wrote in message

> 512 MB of RAM


Apr 6, 2004, 8:34:50 AM4/6/04
I took your advice and allocated the maximum amount of virtual memory.
However, the maximum paging file size can be set to a max value of only 4096 MB
while being greater than or equal to the initial I entered 4096 MB in
both fields (initial and max). Also, I made sure my processor scheduling and
memory usage is adjusted for programs only and not to background programs nor
system cache. I restarted my computer and tried to open the flash file, but it
STILL gives me that error message. After all this trial and error stuff I've
done, I'm thinking that this error is a fault in the program and has nothing to
do with my system settings. After all, I [i]did[/i] open this file succesfully
many times before, and now, [i]suddenly[/i] this error thing comes up. Is
there anything else I can do to fix this problem? Any updates (besides the
7.0.1 update, I already have that), fixes, or procedures you recommend? I
really don't want to have to delete this flash file I've been working on.

James Fee

Apr 6, 2004, 8:43:38 AM4/6/04
It sounds like the file has been corrupted. If you have a backup somewhere
of an older version, I would start with that.

Jim Fee
Viking Electronic Services
jfee (at) vikinges (dot) com


Apr 6, 2004, 9:35:37 AM4/6/04
Don't have a backup. In fact, I transferred this flash file via CD to a
friend's computer who also has Flash MX 2004 and it opened successfully. I
don't think the file's corrupt. Any other suggestions?


Apr 6, 2004, 9:40:37 AM4/6/04
Another option is to test the file on another system.
Also, does the error only occur with the one fla file?
Perhaps reinstalling the Flash program will resolve the issue.

"James Fee" <> wrote in message


Apr 6, 2004, 10:33:07 AM4/6/04
Try reinstalling Flash

"Dave" <> wrote in message


Apr 7, 2004, 8:21:10 AM4/7/04
I already reinstalled Flash many times (I think I already said this earlier). I even tried reinstalling reinstalling Flash in Safe Mode and the error STILL comes up when i try to open the flash file.


Apr 7, 2004, 10:44:56 AM4/7/04
I don't know what could be the problem if the file works fine on a different
machine. Must be something related to your system. Weird that reinstalling
Flash didn't solve the issue.
This is extreme, but you may need to format C: and start fresh.

"HVnitro006" <> wrote in message



Jul 21, 2004, 8:09:13 PM7/21/04
Did you ever resolve your memory problem? I'm running winXP pro with a gig of
RAM and I get the same error message. I've re-installed winxp, Flash MX 2004
and have tried it on another nearby computer. When I look at the task manager,
I can see that flash is not using very much memory and there is plenty of
system memory available. This is the second time this has occured. I do have
a back-up but it is a rev or two behind and I would prefer not having to re-do
my work. Any advice will be greatly appreciated ... beside making more
up-to-date backups ;) Thanx.


Jul 21, 2004, 8:33:24 PM7/21/04
I get the same problem when I export the file or publish. I get an error that
says "not enough memory to complete the task". I never had that problem with
my other files. You think if I start over, it may work? I spent so much time
on it though. Is there a limit to how much video or anything when creating a
flash file? I wouldn't think there would be.



Jul 21, 2004, 11:06:06 PM7/21/04
Second try at replying ...

For anyone who cares ... no one? :) Oh well. Although I do not know the
exact reason for my error message, I think it is related to the library ...
linkage problem? I tried to trace back what I did prior to the error message
(not wanting to redo everything) and realized that when I imported a series of
images replacing an older set, it didn't replace one image in the middle. I
checked the images I was trying to import and they were fine. I tried
importing the series several times with the same results (this is even after
doing a cold-restart of my system and flash) So this time, I eliminated the
series from the library before importing and was successful. I saved the file
and was able to load it without any error messages.

And here's a lame link about for

Xystren Lightenstien

Jul 22, 2004, 12:37:07 PM7/22/04
I've had a couple memory issues, but it's more been from memory leaks.
Doing a reboot mostly fixes everything (temporarally at least).

As for size of files, I've worked with a 270meg AVI file and have
converted to a FLV (which came down to about 30megs). So for size of
files and such, I wouldn't imagine it should be a problem.. (BTW, that
was done on a dual P3-500 with 256megs ram...since then I've dropped in
another 512mb which makes things better on a whole <can't imagine why,
chuckle>, granted no speed records were broken, but it did chugg through
all ok.



Jul 22, 2004, 4:08:37 PM7/22/04
Heard of this issue a couple of times.
My fren got the error too, running on a P4 comp, so I was quite surprise.
He end up going back using mx.
I wonder whats the problem


Sep 9, 2004, 6:09:50 PM9/9/04
Here is the best part about this crappy error message that I too have received,
its for the Mac. Not even for OSX, but for the old Classic Mac OS (Mac OS 9,
8, 7, etc). There is no "Finder" in any version of Windows, nor is there a way
to allocate more memeory to any program. These are all functions of the old
Macintosh operating system. Even OSX doesn't have a way to allocate more memory
to specific apps.

How it made its way into the windows version is either a practical joke or
confirms that programmers at Macromedia really are monkeys, sitting in a room
banging on the keyboard waiting for a program to emerge from their nonsense

Unfortunately I was unable to find a solution. It is almost certainly related
to the Library getting overloaded with stuff. I had a ton of bitmap graphic
animations and such. I tried opening it on several other computers, updated
Flash to latest version, added more RAM (2gigs on a dual 2ghz G5), and still
got that lame error message. Finally, it just worked and didn't crash when I
opened the library. I was able to trim out the unwanted fat and now things are
smooth sailing. May only be specific to MX 2004.

Hope this helps. Hope Macromedia pulls their act together...


Sep 9, 2004, 11:44:29 PM9/9/04
fla files may get bloated in filesize each time you open and save, even if you
deleted assets in the file, your old library assets will still be kept in the
fla. It's been a known bug/feature. =P In flash mx 2004, they finally addressed
this and have a save and compact feature. That might help with your memory
problems by lowering the overall filesize of your .fla file. And for other
version of flashs, like suggested in the earlier post, do a "File and save as"
with a new name, to get reduce your filesize if you notice your .fla file

Several books mention this and suggest workarounds, like "Flash Hacks" by Sham
Bhangal. Also you can read this thread that goes into bloating problem:


Sep 23, 2004, 7:11:00 PM9/23/04
I just bought Flash MX 2004, and I'm having the same memory problem and getting
the same stupid error message about a Finder. My file is only 15 mB, and
previous to today, I was opening this file along with Photoshop and Thumbs
Plus. So I don't know what the problem is, but I'm getting pretty tired of it!


Sep 28, 2004, 12:15:40 PM9/28/04
I, too, am the unhappy recipient of this memory problem. I feel your pain. I
have tried reinstalling Flash, opening on a different system, opening on a
different platform, reverting to a backup version a few weeks old, and NOTHING
works. Literally, a file that worked fine for weeks has suddenly gone bad...

What I was able to do, however, was to open my Mac file on a trial version for
Windows, and go through and delete scenes, Save and Compact, then Save and
Compact AGAIN to get rid of anything that was unused. That's when I had the
breakthrough. One of the scenes kept causing the memory error to come up, no
matter what I did to correct the issue. When I looked on the stage, one of the
PNGs that I had imported was mysteriously blank. After I deleted it from the
library, the file saved just fine.

I then thought, what if I delete only that item from the huge file? Holy crap,
it worked. Sure, I have to go back and fix fonts and stuff, but that's better
than losing a week's worth of work. Hopefully my experience will be of some

Reply all
Reply to author
0 new messages