Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.

Transient errors: Invalid Method Signature

Skip to first unread message


Nov 3, 2003, 10:55:02 AM11/3/03
I'm seeing transient errors daily on one of our Windows CFMX 6.1 Standard servers. They're all various kinds of java's "Invalid method signature error". These errors always go away when the page is refreshed. This kind of instability is very unsettling to me and my users. I can't find anything about this on the forums or These errors seem to occur regardless of Trusted Cache setting, but they seem to happen less often when Trusted Cache is on. I hope some Java guru can help figure out what's going wrong.

Here are some of the errors:

Invalid method signature: tring;)Ljava/lang/Object; null
Invalid method signature: ava/lang/Object;)Ljava/lang/Object; null
Invalid method signature: /Object; null
Invalid method signature: ava/lang/String;)V null
Invalid method signature: ;)V null
Invalid method signature: (Ljava/lang/String;)Ljava/lang/StringBuffer; null
Invalid method signature: (Ljava/lang/String;[Ljava/lang/String;)Ljava/lang/Object; null
Invalid method signature: g;)Ljava/lang/Object; null
Invalid method signature: runtime/CFPage;[Ljava/lang/Object;)Ljava/lang/Object; null
Invalid method signature: ;)Ljava/lang/Object; null
Invalid method signature: /String;)Ljava/lang/Object; null

Thanks for reading this! I'm pretty desperate for a fix to this problem.



Nov 7, 2003, 12:21:31 PM11/7/03
I've got some more information on this problem. It seems to only happen when using the evaluate() function, and it is a transient problem. I haven't been able to correlate it with load conditions.

It doesn't seem to matter much what I'm passing into evaluate(). I use it to get at data in dynamically named queries, replace placeholders in text with labels, and run dynamically-generated CFScript. All of these events can trigger the error.

I'm aware that evaluate() is not always the best way to do things, but it is sometimes far more convenient than other methods, and in some cases is the only reasonable way to accomplish a task.

It seems to me that this is a bug in evaluate(). Anyone from Macromedia willing to take a look at this problem?



Mar 3, 2004, 5:36:15 PM3/3/04
I have just gotten the same error - also when using the Evaluate function. It has only happened once though - the rest of the time it is running the same code fine.


May 5, 2004, 4:50:38 PM5/5/04
I've been getting this error only after MX is restarted and the classes
directory is purged and it happens when I CFINCLUDE a template. The templates
compile as desired if the page is refreshed and never happans again until I
repeat the process of stopping MX and flushing the classes directory (but it
doesn't always happen).

Invalid method signature: (Lcoldfusion/runtime/Variagle;


Feb 1, 2005, 4:18:10 PM2/1/05
I am experiencing a similar problem myself, did any of you ever find a solution to this error?


Jul 1, 2005, 5:23:11 AM7/1/05
I'm experiencing same problem too. but it only happen to coldfusion server
running on linux. It never happen to my coldfusion server running on windows.
I'm using CFMX6.1 also. Anybody can help ???? really need it..


Aug 25, 2005, 8:17:53 PM8/25/05
Has anyone been able to resolve this issue? I have now encountered the same
problem (I am utilising fusebox 4.1). The application has been running fine on
our development server, and now since moving to our live server 2 days ago, the
error has occurred 3 times after limited testing - once again, as soon as the
page is refreshed the page loads ok. The specifications of software/versions on
both machines is identical.

Is there anyone associated with Macromedia who can shed any light on this
because I think the number of people here who have expressed their problems of
this without any resolution is a worrying issue!?


Aug 30, 2005, 9:01:49 AM8/30/05
I'm experiencing same problem too.

Invalid method signature: ;[Ljava/lang/String;)Ljava/lang/Object; null <br>The error occurred on line 184.

Oct 5, 2005, 11:47:50 AM10/5/05
I have the same issue...
Invalid method signature: e/Variable;)Ljava/lang/Object;

Is anyone listening here?
I'm going to look at the evaluate() idea and see if that has anything to do
with it but. MM need to answer us on this one!


Oct 5, 2005, 12:34:53 PM10/5/05
We fixed this in 7.0.1 but the workaround would be to uncheck "Save Class
Files" (and delete the /cfclasses directory).

The bug we logged is 59825. It was a sync issue with the evaluate() call -
too technical to get into here. A public hotfix wasn't made available.

This fix made it into 7.0.1. You can call support to get the 6.1 hotfix or
you can just use the workaround.

Stephen Dupre
Macromedia QA


Nov 8, 2005, 11:21:14 AM11/8/05
You can call support to get the 6.1 hotfix\

The only problem is that support wants $499 in advance (which will be
refunded, due to the MM post above stating that it is a bug) and they cannot
seem to get my creditcard data into the system.
Is this hotfix available somewhere other than through the rather tedious
procedure of calling support?


Jan 23, 2006, 8:17:23 AM1/23/06
Our clients at Pfizer are entirely unimpressed with us due to this bug
intermittentally reoccurring in a application we have developed for them. The
application is critial and this bug can not be tolerated.

We have tried installed the ColdFusion 6.1 updater, cleared class files and
unchecked "Save Class Files". However the Invalid Method Signature error stills
occurs every now and then.

Explaining that this is a bug in ColdFusion and not our code sounds like an
excuse that they won't (and shouldn't) accept.

I tried searching this site for the hot fix you mentioned with no success.
This page provides
no hot fix for this issue.

Forcing our clients to upgrade to ColdFusion MX 7 because you guys have a bug
in your 6.1 product is, to say the lease, unfair. Please provide a direct link
to the hot fix for this problem.

0 new messages