Looking for help with ALSA

1 view
Skip to first unread message

mscott pyewacket.org

unread,
Aug 12, 2022, 4:32:45 PM8/12/22
to AALUG Mailing List
I recently set up a computer to play a series of video files using vlc.
Everything works except the sound comes out of the PC speaker rather than the speakers on the connected HDMI monitor.
The OS is Debian bullseye (11.4.0) with non-free drivers.
I believe the hardware is being recognized, but since the display was not connected when I installed the OS, it isn't the default.
I've been looking at stuff online and my eyes are starting to glaze over.
Is there a config I can change to switch the default output device to one of the HDMI outputs?
I'm willing to apply trial-and-error.

aplay -l is as follows:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3234 Analog [ALC3234 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Thanks in advance.

- Mike Scott
Reply all
Reply to author
Forward
0 new messages