Help with a Linux-hostile computer

0 views
Skip to first unread message

mscott pyewacket.org

unread,
Aug 1, 2022, 12:01:13 PM8/1/22
to AALUG Mailing List
I recently set up a new desktop system with an Asus Prime Z370-A motherboard.
The on-board video appears to have a problem displaying graphics.

I first tried debian 11.4 and it appeared to install fine, however, when it booted, instead of the graphical login screen, I just got a white screen with nothing displayed.
I then tried Fedora (latest, I think 35 something) live boot. That booted up with just the desktop background and no controls or icons.
Same with Ubuntu LTS. I could get the live system to work in "Safe graphics" but the install booted to the same blank screen.

The OS is running as I can switch to another vtty screen and run commands, just graphics has issues.
All I get from the Asus ReadMe is: "Please update to the latest Linux Kernel for motherboard chipset and components support."

The only thing I haven't tried yet is apt update/upgrade but all of these kernals are way newer than the mobo.
Is there a specific driver I need to install? The manual says it uses the Intel Z370 chipset.

Thanks for any ideas you can provide.


- Mike Scott

Reply all
Reply to author
Forward
0 new messages