Undefined reference to 'CALLBACK_USB_GetDescriptor'

27 views
Skip to first unread message

František Beránek

unread,
Sep 4, 2020, 3:47:38 AM9/4/20
to LUFA Library Support List

Hi,
I'm getting mentioned error while trying to compile my project using LUFA. Strange thing abou that is that my Atmel Studio 7 can find this function by using 'go to implementation', so I think that I'm using all includes properly. Also I tried to place some error message to device.h file to see if compiler can find this file and it worked.
I'm sorry for spam if it's some stupid problem, but my nerves are stretched now.
Thank you for your answer.

Benjamin Riggs

unread,
Sep 4, 2020, 8:30:16 PM9/4/20
to lufa-s...@googlegroups.com
Assuming you have this function defined in your codebase somewhere, this sounds suspiciously like an issue with linker order. Ensure that your definition is in a file linked after the main library files.

--
You received this message because you are subscribed to the Google Groups "LUFA Library Support List" group.
To unsubscribe from this group and stop receiving emails from it, send an email to lufa-support...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lufa-support/3a0aa709-25c8-42b1-bbff-21bb2ea12010n%40googlegroups.com.


--
Benjamin Riggs
Pronouns: He / Him
Founder & CEO
Entropic Engineering LLC
670 Transfer Rd
St Paul, MN 55114

František Beránek

unread,
Sep 7, 2020, 3:15:53 AM9/7/20
to LUFA Library Support List
Thank You for answer.
In my source file I include USB.h. All Lufa files are unchanged and I'm trying to call USB_Init function in my main fuction.

Dne sobota 5. září 2020 v 2:30:16 UTC+2 uživatel Benjamin Riggs napsal:
Reply all
Reply to author
Forward
0 new messages