Cap 22 -Gradle

5 views
Skip to first unread message

Janfrancisco Ramalho

unread,
Mar 27, 2016, 6:38:37 PM3/27/16
to Livro Dominando o Android
Olá Glauber. Conforme sugestão sua na pag. 671, em que podiamos criar um flavor para a versão 2.3 e outro para a 3.0, tentei simular incluindo na versão para o seguinte comando: monSdkVersion 10, porém ao executar dá o seguinte erro:

 Error:Execution failed for task ':app:processPagoDebugManifest'.
> Manifest merger failed : uses-sdk:minSdkVersion 10 cannot be smaller than version 15 declared in library [Ex40_Gradle:minhalib:unspecified] D:\Android\Android_Projects\Ex40_Gradle\app\build\intermediates\exploded-aar\Ex40_Gradle\minhalib\unspecified\AndroidManifest.xml
 
Suggestion: use tools:overrideLibrary="dominando.android.minhalib" to force usage


Poderia me ajudar a resolver este problema. Parece que é no manifest do modulo MinhaLib, mas não consegui encontrar o erro.

Antecipadamente agradeço

nglauber

unread,
Mar 27, 2016, 10:47:56 PM3/27/16
to Livro Dominando o Android
Oi Janfrancisco, 

Tenta colocar o minSdk do app e da minhalib com os mesmos valores.

4br4ç05
nglauber
Reply all
Reply to author
Forward
0 new messages