[go-nuts] liteide x34.3 released, support go1.11 modules

16 views
Skip to first unread message

visualfc

unread,
Oct 5, 2018, 9:34:52 PM10/5/18
to golang-nuts, Golang-China, liteide-dev
Hi, all.
LiteIDE X34.3 released!
This version fix bug and support go1.11 modules


### 2018.10.05 Ver X34.3
* LiteIDE
	* fix support go1.11 modules
* GolangEdit
	* fix jump import line
	* fix find usages for import line
* LiteEditor
	* fix gocode completer item kind update
* GolangCode
	* enviroment changed to reset gocode
* gotools & gocode
	* types: fix module-based project with several subpackages https://github.com/visualfc/liteide/issues/977
	* types: fix redeclared file parser cursor first
	* types: fix source file update check in stdin
	* types: fix x test files check
	* gomod: fix lookup module for go list
* gocode
	* fix gocode crash https://github.com/visualfc/liteide/issues/978

Reply all
Reply to author
Forward
0 new messages