Troubleshooting Lita's Docker image

40 views
Skip to first unread message

Nathaniel Irons

unread,
Apr 5, 2016, 6:54:47 PM4/5/16
to Lita
Hi folks,

I’m trying to get up to speed simultaneously with both Lita and Docker, and getting myself into trouble. When I run the lita:latest container, startup aborts early. Here’s the console log:

Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
installing your bundle as root will break this application for all non-root
users on this machine.
Could not locate Gemfile
Could not locate Gemfile

Can anyone suggest an approach to take? I’m using Docker 1.9.1, on OS X 10.11.4.

Thanks,

  -nat

Jimmy Cuadra

unread,
Apr 8, 2016, 7:48:30 PM4/8/16
to Nathaniel Irons, Lita
Hi there,

The Docker image for Lita is intended for deploying a Lita code repository. Depending on what you're trying to do, using the Docker image may not be the right choice. The image is documented in the README at https://github.com/litaio/docker-lita, with more detailed deployment instructions at https://docs.lita.io/getting-started/deployment/. If you can provide some more specific information about what you're trying to achieve and what command you're running to do it, I can offer more specific suggestions.

Jimmy

--
You received this message because you are subscribed to the Google Groups "Lita" group.
To unsubscribe from this group and stop receiving emails from it, send an email to litaio+un...@googlegroups.com.
To post to this group, send email to lit...@googlegroups.com.
Visit this group at https://groups.google.com/group/litaio.
To view this discussion on the web visit https://groups.google.com/d/msgid/litaio/9b42f32a-8ba0-43f3-84f2-1092c0c4b5d6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

signature.asc
Reply all
Reply to author
Forward
0 new messages