translation missing

39 views
Skip to first unread message

aloysiu...@gmail.com

unread,
Dec 13, 2019, 5:13:04 AM12/13/19
to Lita
Hello everyone

Dose anyone meet this error?

[2019-12-13 10:09:58 UTC] FATAL: translation missing: zh-TW.UTF-8.lita.config.missing_required_adapter_attribute

And how can I put translation file into folder?

thks a lot :)

Jimmy Cuadra

unread,
Dec 13, 2019, 9:47:57 PM12/13/19
to aloysiu...@gmail.com, Lita
Hi Aloysius,

That error comes from a combination of two issues:

1. A translation of the error message with the key "lita.config.missing_required_adapter_attribute" is not available for the zh-TW locale. My understanding is that the i18n system is supposed to fall back to the default localization if a translation is not present. I don't know off hand why that didn't happen in this case. That makes it pretty confusing!
2. The English version of this error is "Configuration attribute "%{attribute}" is required for "%{adapter}" adapter." where the name of the missing attribute and the name of the adapter are interpolated. This means that the Lita adapter you're using requires a value for a configuration attribute that has not been set in lita_config.rb. Unfortunately the translation issue suppressed the default message so you weren't given information about which required attribute was missing.

A quick workaround would be to change the locale back to its default "en" so that you can see which configuration attribute is missing. A longer term fix would be to add the missing translation to a locale file for zh-TW. Debugging and fixing the i18n fallback behavior would also be a nice improvement.

Hope this helps,
Jimmy

--
You received this message because you are subscribed to the Google Groups "Lita" group.
To unsubscribe from this group and stop receiving emails from it, send an email to litaio+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/litaio/f6e41db0-14da-4b1b-9300-746740c6c08c%40googlegroups.com.

Reply all
Reply to author
Forward
0 new messages