Kernel panic with UBIFS

171 views
Skip to first unread message

Konstantin B

unread,
Jan 27, 2012, 12:30:50 PM1/27/12
to linuxstamp
Hello,
I am trying to compile my own kernel and load it onto the LS2_9260 and
I keep getting the following error when the kernel is trying to boot:

VFS: Cannot open root device"ubi0_0" or unknown -block(0,0)
Please append a corrent "root=" boot option

The boot option that I am using is the one that is mentioned in the
LS2 wiki:
mem=32M console=ttyS0,115200 rootdelay=0 ip=192.168.0.51 ubi.mtd=5
root=ubi0_0 rootfstype=ubifs

I have compiled the kernel using ELDK 4 and the compilation process
runs smoothly.
My guess is that my configuration of the kernel before compilation is
lacking something, I have made sure to select the AT91SAM9260
processor, and selected the Atmel AT91SAM9260-EK option (I also made
sure to change the machine id in mach-type so I no longer get the
machine id error as I did when I first started).
Under miscellaneous filesystems I selected the UBIFS file system
support.

I am loading the kernel through minicom and the FTDI connection to ram
and then copy it to nand flash, when I reboot I get the kernel panic
error. If I load the uImage.9260r2 that is provided on the ftp site,
the LS2 is working again.
I have also tried to copy the kernel source on the ftp site and
compile using the .config in there and I still received the kernel
panic error.
I have tried several different kernel versions and am pretty much at a
loss as to what to next.
Thank you,
Konstantin Borschiov

Paul Thomas

unread,
Jan 27, 2012, 4:58:33 PM1/27/12
to linux...@googlegroups.com
Yeah it does look like a fs issue. You need more than just ubifs
there's other ubi & nand modules that are needed. You can look at the
.config in the kernel source on the ftp site.

I would suggest for development using the rootnfs.

thanks,
Paul

> --
> You received this message because you are subscribed to the Google Groups "linuxstamp" group.
> To post to this group, send email to linux...@googlegroups.com.
> To unsubscribe from this group, send email to linuxstamp+...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/linuxstamp?hl=en.
>

Reply all
Reply to author
Forward
0 new messages