Bug#994590: linux-image-5.10.0-8-amd64: ath9k AR9264 wifi doesn't work, dropping packet

185 views
Skip to first unread message

tenaka

unread,
Sep 18, 2021, 5:10:03 AM9/18/21
to
Package: linux-image-5.10.0-8-amd64
Version: linux-image-5.10.0-8-amd64
Severity: important

Dear Maintainer,

i have upgraded my system with debian from buster to bullseye and my wifi
connection perfectly working on buster it became unusable on bullseye, when the
system with bullseye start the wifi seems working but after some minutes it
stops, can't ping and can't resolve the hostname.
"journalctl -p err -b" shows no issues.

after backup my system with a clonezilla backup image
i tried to reinstall bullseye anew, it can't finish to download the packet via
wifi, it gets stuck after some packets were downloaded.

no error were reported.

my laptop is "ASUSTeK_COMPUTER_INC_G750JZ"

the device who shows a regression on bullseye is

"03:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter
(rev 01)"

thank you




-- System Information:
Debian Release: 10.10
APT prefers oldstable-updates
APT policy: (500, 'oldstable-updates'), (500, 'oldstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-17-amd64 (SMP w/8 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8), LANGUAGE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Tenaka Khan

unread,
Dec 11, 2021, 12:30:04 PM12/11/21
to
i have found a solution, more like a workaround really but it helps to
add context to the problem.

i changed the wifi card from an atheros AR9462 to an atheros AR9485 that
showed the same type of behaviour: packet dropping , connection
reconnect to the ap, exactly the same pattern of regression but when i
was checking the dmesg log

it showed something about irq been remapped and reconnection occour.

[ 2364.308768] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000028
AR_DIAG_SW=0x02000020 DMADBG_7=0x0002a800


i google it and found a workaround here :
https://wiki.archlinux.org/title/Network_configuration/Wireless#Cause_#5

i added the "intel_iommu=off" to the kernel at boot and everything
worked like a charm.

so just out of curiosity i switched back to the atheros AR9462 and tried
the same and it worked too.

so this is it.

--
Tenaka Khan

tena...@gmail.com
Reply all
Reply to author
Forward
0 new messages