Bug#474951: lighttpd: Extremely high load with HTTPS sites after update

1 view
Skip to first unread message

Matthias Kellermann

unread,
Apr 8, 2008, 3:10:09 AM4/8/08
to
Package: lighttpd
Version: 1.4.13-4etch7
Severity: critical
Justification: breaks the whole system

After upgrading lighttpd from 1.4.13-4etch6 to 1.4.13-4etch7 I got the
following error messages in error.log when opening a HTTPS site with a
self-signed SSL certificate:

2008-04-08 08:38:05: (connections.c.1649) SSL: 5
error:00000000:lib(0):func(0):reason(0)

The load on the system rises extremely high so the whole system gets
unusable and I have to stop lighttpd. Switching back to 1.4.13-4etch6
fixes the problem. This happened on several Etch machines.

-- System Information:
Debian Release: 4.0
APT prefers stable
APT policy: (500, 'stable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-5-686
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)

Versions of packages lighttpd depends on:
ii libattr1 2.4.32-1 Extended attribute shared library
ii libbz2-1.0 1.0.3-6 high-quality block-sorting file co
ii libc6 2.3.6.ds1-13etch5 GNU C Library: Shared libraries
ii libldap2 2.1.30-13.3 OpenLDAP libraries
ii libpcre3 6.7+7.4-3 Perl 5 Compatible Regular Expressi
ii libssl0.9.8 0.9.8c-4etch1 SSL shared libraries
ii lsb-base 3.1-23.2etch1 Linux Standard Base 3.1 init scrip
ii mime-support 3.39-1 MIME files 'mime.types' & 'mailcap
ii zlib1g 1:1.2.3-13 compression library - runtime

Versions of packages lighttpd recommends:
ii php4-cgi 6:4.4.4-8+etch4 server-side, HTML-embedded scripti
ii php5-cgi 5.2.0-8+etch10 server-side, HTML-embedded scripti

-- no debconf information

--
To UNSUBSCRIBE, email to debian-bugs-...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listm...@lists.debian.org

Reply all
Reply to author
Forward
0 new messages