Bug#602541: pidgin: Logon to ICQ no possible

19 views
Skip to first unread message

Frank Lanitz

unread,
Nov 5, 2010, 2:30:02 PM11/5/10
to
Package: pidgin
Version: 2.7.4-2
Severity: normal

Currenty its not possible to connect with ICQ network in soem
situations. This has been fixed with 2.7.5 upstream release.

-- System Information:
Debian Release: squeeze/sid
APT prefers unstable
APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.36-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages pidgin depends on:
ii gconf2 2.28.1-5 GNOME configuration database syste
ii libatk1.0-0 1.30.0-1 The ATK accessibility toolkit
ii libc6 2.11.2-7 Embedded GNU C Library: Shared lib
ii libcairo2 1.8.10-6 The Cairo 2D vector graphics libra
ii libdbus-1-3 1.2.24-3 simple interprocess messaging syst
ii libdbus-glib-1-2 0.88-2 simple interprocess messaging syst
ii libfontconfig1 2.8.0-2.1 generic font configuration library
ii libfreetype6 2.4.2-2 FreeType 2 font engine, shared lib
ii libglib2.0-0 2.26.0-1 The GLib library of C routines
ii libgstreamer0.10-0 0.10.30-1 Core GStreamer libraries and eleme
ii libgtk2.0-0 2.20.1-2 The GTK+ graphical user interface
ii libgtkspell0 2.0.16-1 a spell-checking addon for GTK's T
ii libice6 2:1.0.6-2 X11 Inter-Client Exchange library
ii libpango1.0-0 1.28.3-1 Layout and rendering of internatio
ii libpurple0 2.7.4-2 multi-protocol instant messaging l
ii libsm6 2:1.1.1-1 X11 Session Management library
ii libstartup-notification0 0.10-1 library for program launch feedbac
ii libx11-6 2:1.3.3-3 X11 client-side library
pn libxml2 <none> (no description available)
ii libxss1 1:1.2.0-2 X11 Screen Saver extension library
ii perl 5.10.1-16 Larry Wall's Practical Extraction
ii perl-base [perlapi-5.10.1] 5.10.1-16 minimal Perl system
ii pidgin-data 2.7.4-2 multi-protocol instant messaging c

Versions of packages pidgin recommends:
ii gstreamer0.10-plugins-base 0.10.30-1 GStreamer plugins from the "base"
ii gstreamer0.10-plugins-good 0.10.24-1 GStreamer plugins from the "good"

Versions of packages pidgin suggests:
pn evolution-data-server <none> (no description available)
pn gnome-panel | kdebase-workspa <none> (no description available)
ii libsqlite3-0 3.7.3-1 SQLite 3 shared library

-- no debconf information

--
To UNSUBSCRIBE, email to debian-bugs-...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listm...@lists.debian.org

bugr...@sogetthis.com

unread,
Nov 6, 2010, 5:40:01 PM11/6/10
to
On Fri, 05 Nov 2010 you wrote:
> Currenty its not possible to connect with ICQ network in soem
> situations. This has been fixed with 2.7.5 upstream release.
Same situation here. I can not connect to ICQ since end of October.
Yet this is persistent, not just in some situations.
I was using pidgin 2.7.3 from lenny bpo.
I verified that i get the same behaviour with pidgin 2.7.3 on squeeze.
I have not tried 2.7.5.

Some more details (logs from squeeze):

The usual error message is:
> Received unexpected response from
> https://api.oscar.aol.com/aim/startOSCARSession: Ok

The debug window says:
> (21:20:46) certificate: Successfully verified certificate for api.oscar.aol.com
> (21:20:46) util: request constructed
> (21:20:47) util: Response headers: 'HTTP/1.1 200 OK
> Date: Sat, 06 Nov 2010 20:20:47 GMT
> Server: Apache
> Content-Length: 642
> Pragma: no-cache
> Cache-Control: no-store,no-cache,must-revalidate
> Keep-Alive: timeout=1, max=87
> Connection: Keep-Alive
> Content-Type: text/xml
>
>'
> (21:20:47) util: parsed 642
> (21:20:47) oscar: startOSCARSession response was missing something: <?xml version="1.0" encoding="UTF-8"?>
> <response xmlns="http://developer.aim.com/xsd/aim.xsd"><statusCode>200</statusCode><statusText>Ok</statusText><data><ts>1289074847</ts><host>205.188.3.84</host><port>443</port><cookie>...</cookie><upgradeData></upgradeData><betaData></betaData></data></response>
> (21:20:47) connection: Connection error on 0xXXXXXXX (reason: 0 description: Received unexpected response from https://api.oscar.aol.com/aim/startOSCARSession: Ok)
> (21:20:47) account: Disconnecting account XXXXXXXXX (0xXXXXXXX)
> (21:20:47) connection: Disconnecting connection 0xXXXXXXX
> (21:20:47) oscar: Signed off.
> (21:20:47) connection: Destroying connection 0xXXXXXXX
(i have removed the cookie)


After unchecking "Use ClientLogin" in Account Preferences, the error message changes to:
> Unable to connect to BOS server: SSL Handshake Failed

with debug window:
> (21:40:47) proxy: Attempting connection to 205.188.3.86
> (21:40:47) proxy: Connecting to 205.188.3.86:5190 with no proxy
> (21:40:47) proxy: Connection in progress
> (21:40:47) proxy: Connecting to 205.188.3.86:5190.
> (21:40:47) proxy: Connected to 205.188.3.86:5190.
> (21:40:48) nss: Handshake failed (-5961)
> (21:40:48) oscar: unable to connect to FLAP server of type 0x0002
> (21:40:48) connection: Connection error on 0xXXXXXXX (reason: 0 description: Unable to connect to BOS server: SSL Handshake Failed)
> (21:40:48) account: Disconnecting account ...

I have not tried to connect without SSL.


The pidgin changelog at http://developer.pidgin.im/wiki/ChangeLog says:
version 2.7.5 (10/31/2010)
AIM and/or ICQ:
# New ICQ accounts default to proper ICQ servers. Old accounts using one of the old default servers will be silently migrated to use the proper servers.
# ICQ accounts using clientLogin now use the correct ICQ servers. This is separate from the server settings mentioned above.

But changing server from slogin.oscar.aol.com to slogin.icq.com
(as suggested by migrate_icq_server() from pidgin-2.7.5/libpurple/account.c)
does not help.

Regards

Reply all
Reply to author
Forward
0 new messages