Bug#520305: pssh: Allow '-' as an alias for stdin

1 view
Skip to first unread message

andy bezella

unread,
Mar 18, 2009, 2:20:16 PM3/18/09
to
Package: pssh
Version: 1.4.3-1
Severity: wishlist

the freebsd port of the pssh toolset has been modified to allow '-' as an alias for stdin in the host file specification (http://www.freebsdsoftware.org/security/pssh.html). this feature is included in other tools (e.g., fping) and is very useful in them. could it be implemented here?

thank you.


-- System Information:
Debian Release: squeeze/sid
APT prefers experimental
APT policy: (999, 'experimental'), (990, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.29-rc8-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages pssh depends on:
ii python 2.5.4-3 An interactive high-level object-o
ii python-support 0.90.3 automated rebuilding support for P

pssh recommends no packages.

pssh suggests no packages.

-- no debconf information

--
To UNSUBSCRIBE, email to debian-bugs-...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listm...@lists.debian.org

Hilmar Preuße

unread,
Sep 16, 2021, 5:50:04 PMSep 16
to
Am 18.03.2009 um 19:07 teilte andy bezella mit:

Hi Andy,

> the freebsd port of the pssh toolset has been modified to allow '-'
> as an alias for stdin in the host file specification
> (http://www.freebsdsoftware.org/security/pssh.html). this feature
> is included in other tools (e.g., fping) and is very useful in them.
> could it be implemented here?
>
I guess you speak about this patch, right?

https://cgit.freebsd.org/ports/tree/security/pssh/files/patch-psshlib_psshutil.py

The change wasn't implemented at upstream yet. Are you willing to test a
patched Debian package?

Hilmar
--
sigfault


OpenPGP_signature

andrew bezella

unread,
Sep 17, 2021, 1:40:03 AMSep 17
to
hello -

On Thu, 2021-09-16 at 23:34 +0200, Hilmar Preuße wrote:
>
> >
> I guess you speak about this patch, right?
>
> https://cgit.freebsd.org/ports/tree/security/pssh/files/patch-psshlib_psshutil.py
>
> The change wasn't implemented at upstream yet. Are you willing to
> test a
> patched Debian package?
>

yes, that looks like it is the patch, thank you!

i'm not using the pssh-suite of tools daily so it wouldn't be an
exhaustive test, but yes, i would be willing to install and try out a
patched .deb.

thanks again!

andy

--
andrew bezella <abez...@archive.org>
internet archive
Reply all
Reply to author
Forward
0 new messages