Bug#1003372: ITP: oci-python-sdk -- Oracle Cloud Infrastructure Python SDK

0 views
Skip to first unread message

Paul Wise

unread,
Jan 8, 2022, 9:40:04 PMJan 8
to
Package: wnpp
Severity: wishlist
Owner: Paul Wise <pa...@debian.org>
X-Debbugs-Cc: debian...@lists.debian.org, debian...@lists.debian.org

* Package name : oci-python-sdk
Version : 2.53.1
Upstream Author : Vyas Bhagwat and others
* URL : https://github.com/oracle/oci-python-sdk/
* License : UPL or Apache
Programming Lang: Python
Description : Oracle Cloud Infrastructure Python SDK

This package is needed by my employer for managing their OCI instances.

I plan to maintain it within the Debian Cloud Team after joining it.

--
bye,
pabs

https://wiki.debian.org/PaulWise
signature.asc

Paul Wise

unread,
May 1, 2022, 1:30:03 AMMay 1
to
Control: outlook -1 blocked by https://github.com/oracle/oci-python-sdk/issues/444

Packaging oci-python-sdk is currently blocked by the extensive
vendoring/forking of Python libraries that upstream does.
Details are available in the bug I have filed upstream.
signature.asc

Paul Wise

unread,
May 25, 2022, 9:20:03 PMMay 25
to
On Sun, 2022-05-01 at 13:20 +0800, Paul Wise wrote:

> Control: outlook -1 blocked by
> https://github.com/oracle/oci-python-sdk/issues/444

Oracle have updated their embedded code copies to versions that are
available in Debian unstable, except for idna, which is still outdated,
and httpsig_cffi, which is a modified copy of an unmaintained project.

They also stated that they intend to move to Python ranged dependencies
for oci-python-sdk version 3.0.
signature.asc
Reply all
Reply to author
Forward
0 new messages