Bug#995011: extrepo: missing most of the external repositories

0 views
Skip to first unread message

Bernhard Ludwig

unread,
Sep 24, 2021, 3:00:03 PMSep 24
to
Package: extrepo
Version: 0.9
Severity: normal
X-Debbugs-Cc: 2kn_4uju...@byom.de

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

* What led up to the situation?
Updating package to 0.9

* What exactly did you do (or not do) that was effective (or
ineffective)?
~$ extrepo search | grep ^Found

* What was the outcome of this action?
returns a list with only 4 repositories
Found janitor:
Found dns-oarc:
Found feistermops:
Found debian_official:

* What outcome did you expect instead?
a list matching https://salsa.debian.org/extrepo-team/extrepo-
data/-/tree/master/repos/debian or alternatively same as v0.8 when run on
bullseye.

Found node_12.x:
Found brave_release:
Found wtf-lts:
Found skype:
Found proxmox-pbs:
Found whonix:
Found docker-ce:
Found jellyfin:
Found element:
Found mobian:
Found haproxy-2.4:
Found weechat:
Found vector:
Found neurodebian_data:
Found proxmox-pve:
Found lihas:
Found bareos:
Found keybase:
Found node_16.x:
Found anydesk:
Found brave_nightly:
Found belgium_eid_continuous:
Found google_chrome:
Found debian_official:
Found winehq:
Found jenkins:
Found wtf:
Found vscodium:
Found whonix_proposed:
Found torproject:
Found proxmox-ceph-pacific:
Found teamviewer_preview:
Found liquorix:
Found proxmox-pmg:
Found node_14.x:
Found steam:
Found msteams:
Found yarnpkg:
Found neurodebian_software:
Found openstack_wallaby:
Found debian_backports:
Found eyrie:
Found x2go:
Found raspberrypi:
Found jitsi-stable:
Found prosody:
Found whonix_developers:
Found opera_stable:
Found postgresql:
Found fai:
Found newrelic:
Found openstack_xena:
Found openstack_victoria:
Found brave_beta:
Found teamviewer_default:
Found whonix_testers:


*** End of the template - remove these template lines ***


-- System Information:
Debian Release: bookworm/sid
APT prefers unstable
APT policy: (700, 'unstable'), (600, 'testing'), (500, 'stable-updates'),
(500, 'stable-security'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 5.10.0-8-amd64 (SMP w/8 CPU threads)
Kernel taint flags: TAINT_USER, TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8),
LANGUAGE=en_US:en
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages extrepo depends on:
ii gpgv 2.2.27-2
ii libcryptx-perl 0.073-1
ii libdpkg-perl 1.20.9
ii libwww-perl 6.53-1
ii libyaml-libyaml-perl 0.83+ds-1
ii perl 5.32.1-5

extrepo recommends no packages.

extrepo suggests no packages.

Andrea Pappacoda

unread,
Oct 18, 2021, 12:30:03 PM (10 days ago) Oct 18
to
Package: extrepo
Version: 0.9
Followup-For: Bug #995011

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

This is likely caused by commit 6b263308 (https://salsa.debian.org/extrepo-
team/extrepo/-/commit/6b2633080e0f19d88f0561af426ac8a46e6180e2). Here's what I
think happened (from my comment on that commit):

This [commit 6b263308] makes most third party repos not available, since they
are marked as compatible only with buster, bullseye and sid. All the supported
repos in extrepo-data must also be updated. vscodium is an example; it is
supported on all Debian distros (the binary is statically linked), but extrepo-
data/repos/debian/vscodium.yaml only lists buster, bullseye and sid as
supported.


-----BEGIN PGP SIGNATURE-----

iIoEARYIADIWIQRm3vFSgpkMIZnvqAGooSioqxzuSQUCYW2c9BQcYW5kcmVhQHBh
cHBhY29kYS5pdAAKCRCooSioqxzuSfOVAP47BbDNKi41FfSS/R8B7SoT9vDe7VF4
2ENjqNgYlL/15wD+I6lJf8t3+9IanDOroXSb65rUT89tRz4n+T0S4l44sg4=
=OMbW
-----END PGP SIGNATURE-----
Reply all
Reply to author
Forward
0 new messages