Bug#1011526: pidgin: fails to start on sway

1 view
Skip to first unread message

Samtinel

unread,
May 24, 2022, 9:40:03 AMMay 24
to
Package: pidgin
Version: 2.14.1-1
Severity: important

Dear Maintainer,
Pidgin 2.14.1 (Debian stable) on Sway fails to start. I installed
pidgin and simply launched it with the "pidgin" command. This is the
same command used in the .desktop.
$DISPLAY is :0, $WAYLAND_DISPLAY wayland-0. $GDK_BACKEND is unset.

In the logs it says (debug flag does not change the output):
(Pidgin:34548): Gdk-CRITICAL **: 15:09:24.143: IA__gdk_display_get_name: assertion 'GDK_IS_DISPLAY (display)' failed
Pidgin 2.14.1

** (Pidgin:34548): WARNING **: 15:09:24.144: cannot open display: unset

I am unsure where to go from here, or what I can try now. If it's a
mistake on my side I apologize. If there's anything I should test,
please feel free to tell me.

Samtinel


-- System Information:
Debian Release: 11.3
APT prefers stable-updates
APT policy: (500, 'stable-updates'), (500, 'stable-security'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 5.10.0-14-amd64 (SMP w/2 CPU threads)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages pidgin depends on:
ii libatk1.0-0 2.36.0-2
ii libc6 2.31-13+deb11u3
ii libcairo2 1.16.0-5
ii libdbus-1-3 1.12.20-2
ii libgdk-pixbuf-2.0-0 2.42.2+dfsg-1
ii libglib2.0-0 2.66.8-1
ii libgstreamer-plugins-base1.0-0 1.18.4-2
ii libgstreamer1.0-0 1.18.4-2.1
ii libgtk2.0-0 2.24.33-2
ii libgtkspell0 2.0.16-1.3
ii libice6 2:1.0.10-1
ii libpango-1.0-0 1.46.2-3
ii libpurple0 2.14.1-1
ii libsm6 2:1.2.3-1
ii libx11-6 2:1.7.2-1
ii libxss1 1:1.2.3-1
ii perl-base [perlapi-5.32.1] 5.32.1-4+deb11u2
ii pidgin-data 2.14.1-1

Versions of packages pidgin recommends:
ii gstreamer1.0-alsa 1.18.4-2
ii gstreamer1.0-libav 1.18.4-3
ii gstreamer1.0-plugins-base 1.18.4-2
ii gstreamer1.0-plugins-good 1.18.4-2
ii sensible-utils 0.0.14

Versions of packages pidgin suggests:
ii libsqlite3-0 3.34.1-3

-- debconf-show failed

Richard Laager

unread,
May 24, 2022, 7:30:03 PMMay 24
to
I really don't know. Are other GTK apps working? If so, GTK 2 apps
specifically?

--
Richard

Richard Laager

unread,
May 26, 2022, 1:40:04 AMMay 26
to
On 5/25/22 02:05, Samtinel wrote:
>> Are other GTK apps working?
>
> Yes, dino-im starts successfully.
>> GTK 2
>
> Uh, this I did not check. I will do that when I get to my terminal later. So you happen to know a simple GTK 2 package I can test on?

I don't. So much stuff has moved to GTK 3 (or now GTK 4), of course.

--
Richard
Reply all
Reply to author
Forward
0 new messages