Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.
Dismiss

Bug#1010866: perl-modules-5.34: perl debugger view code is broken in 5.34.0-4 - upstream patch avail

56 views
Skip to first unread message

wdh

unread,
May 11, 2022, 4:10:03 PM5/11/22
to
Package: perl-modules-5.34
Version: 5.34.0-4
Severity: important
Tags: patch

Dear Maintainer,

when upgrading perl modules, the debugger broke:

Undefined subroutine &DB::cmd_l called at .... perl5db.pl line 6034.

This is caused by:
https://github.com/Perl/perl5/issues/19170

and easily patched (is patched in upstream):

https://github.com/Perl/perl5/commit/88121ddb6325200e9e9ea6ffda061de3f75c8bf0

or - to stay on 5.34, use
https://github.com/Perl/perl5/blob/v5.34.1/lib/perl5db.pl



-- System Information:
Debian Release: bookworm/sid
APT prefers unstable
APT policy: (500, 'unstable'), (500, 'stable'), (500, 'oldstable'), (10, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.17.5-3-siduction-amd64 (SMP w/8 CPU threads; PREEMPT)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages perl-modules-5.34 depends on:
ii dpkg 1.21.7
ii perl-base 5.34.0-4

Versions of packages perl-modules-5.34 recommends:
ii perl 5.34.0-4

perl-modules-5.34 suggests no packages.

-- no debconf information
0 new messages