lintVersion "30.1.0-alpha03" breaks isWarningsAsErrors

33 views
Skip to first unread message

colto...@protonmail.com

unread,
Jul 17, 2021, 1:58:06 AM7/17/21
to lint-dev
I have a project with lint = "30.1.0-alpha02"

And the lint module has this block defined

lintOptions {
isWarningsAsErrors = true
disable("GradleDependency")
}

and my app module has this defined

lint {
isWarningsAsErrors = true
disable(
"GradleDependency",
"ObsoleteLintCustomCheck",
)
}

everything works fine. I updated to 30.1.0-alpha03

and now 

```
lintOptions {
isWarningsAsErrors = true
disable("GradleDependency")
}
```

the isWarnings... and disable... are red. Am I using the wrong apis or am I doing something wrong here? Or did alpha03 break something accidentally?


Screen Shot 2021-07-17 at 1.57.44 AM.png
Reply all
Reply to author
Forward
0 new messages