We have a tiny patch that we feel would better live upstream, so that we can name lib worker threads, which is helpful when debugging a program with a lot of threads (in gdb, or with perf top etc...).
We use it to give the same name to all the worker threads but we could probably add a _1, _2 et.... for each of them. Or maybe we don't even need to do that, and libuv could name those threads itself ?
Also we have a function to query how many idle threads there are (uv_queue_work_idle_threads).
How does the community feel about those ? Should we start making PR for that ?