[リリース] v2.5.0 / v3.5.0

368 views
Skip to first unread message

ちとらけんすけ

unread,
Jul 1, 2017, 11:20:08 AM7/1/17
to Lhaz
JPCERTコーディネーションセンターからLhaz/Lhaz+の脆弱性について連絡があり、
Lhaz v2.5.0 / Lhaz+ v3.5.0
をリリースしました。

ちとらけんすけ

unread,
Jul 2, 2017, 12:08:13 AM7/2/17
to Lhaz
32ビットバイナリが動作しなかったのでファイルを差し替えました。

t05

unread,
Jul 2, 2017, 8:48:52 AM7/2/17
to Lhaz
久しぶりにサイトを覗いてみると更新があったので驚きました。お疲れ様です。

早速更新しましたが、「プログラムと機能」での表示が2.4.0のままになっていました(Lhazのバージョン情報では2.5.0になっている)。
その為、試しにアンインストールしたところ、なぜかアンインストールがうまく行われず、ファイルが残った状態になっていました。
手動でファイルを削除後に再度インストールしたところ、やはりバージョンは2.4.0のままで、アンインストールするためのファイル(setup.exe /u?)が作成されていないためか、
CCleanerでレジストリをクリーンアップすると「プログラムと機能」からLhazの項目が削除されます。

環境はWindows7 SP1 x64,Lhaz 2.5.0 x64(7/2差し替え版?)です。
お手数ですが、「プログラムと機能」のバージョンナンバーとアンインストールの動作について確認お願いします。

ちとらけんすけ

unread,
Jul 2, 2017, 11:47:41 PM7/2/17
to Lhaz
>早速更新しましたが、「プログラムと機能」での表示が2.4.0のままになっていました(Lhazのバージョン情報では2.5.0になっている)。

すみません更新が久しぶりで、更新が漏れていました。
次版で忘れないようにバージョン上げます。

>その為、試しにアンインストールしたところ、なぜかアンインストールがうまく行われず、ファイルが残った状態になっていました。

Program Files\Lhaz\配下のファイルを消す処理は行っていないため、お手数ですが手動での削除をお願いします。
今後、削除するようにしていきたいです。

kuma

unread,
Jul 3, 2017, 1:19:22 AM7/3/17
to Lhaz
Lhaz復活うれしいです
XP環境もまだ対応していただいでるみたいで助かります
インストールの話が出てるみたいなので私も一つ要望なんですが
LhazとLhaz+の両方いれてます
インストール時の設定も別にしたいしアンインストールも後にインストール
した片方しか表示されないので別々にインストール(アンインストール)出来るようにして欲しいです
ご検討よろしくお願いします

t05

unread,
Jul 3, 2017, 8:11:41 AM7/3/17
to Lhaz
返信ありがとうございます。

ファイルの削除については、ヘルプの方でも確認しました。確認不足で申し訳ありません。
また、アンインストールについてですが、他の環境(Windows8.1 x86,Windows10 x64)でも同じ状況(CCleanerでレジストリをクリーンアップすると一覧から消える)になり、
試しにCCleanerを使用しない状態で 「プログラムと機能」からLhaz 2.50をアインインストールしようとすると、
「すでにアンインストールされています 一覧から削除しますか?」というようなメッセージが出ました。
その後、ファイルを削除してから再度インストールを行ったところ、設定が保持されたままになっていました。

2.40をアンインストールした際は、どの環境でもエラーメッセージが出ずに設定のみ削除された状態だったので、
2.50でアンインストールの際に何らかの不具合が起こっているのかなと思い再度書き込みます。

ちとらけんすけ

unread,
Jul 4, 2017, 7:02:52 AM7/4/17
to Lhaz
インストール時の設定も別にしたいしアンインストールも後にインストール
した片方しか表示されないので別々にインストール(アンインストール)出来るようにして欲しいです

今回自分もとまどったところになりますので、ご要望として対応進めたいと思います。
 

ちとらけんすけ

unread,
Jul 4, 2017, 7:06:16 AM7/4/17
to Lhaz
2.50でアンインストールの際に何らかの不具合が起こっているのかなと思い再度書き込みます。

確認したところ、ご指摘の通り不具合(原因:setup.exeが同梱されていない)でした。
リリースファイル差し替えか、v2.5.1 / v3.5.1 リリースか(開発意欲が復活したので)したいと思います。
Reply all
Reply to author
Forward
0 new messages